Pose Copier Problems

I’ve been using toon boom for a few months now and for the most part enjoyed the switch over from that other program.

But I’ve had a number of issues with the pose copier that prevent me from using it effectively.

Most importantly on my current rig regardless of what I try pose copier will throw the “selected destination doesn’t match” error

I have set the destination and tried the pasting by name setting instead/in addition and it simply continues to throw the same error.
I’m not sure if there is some higher level node structure or if something in my puppet is making it unworkable but I can’t find any reference to why this error is coming up with the destination most certainly does match.

A lesser problem I’ve been having is when I can get pose copier to work it will insert a drawing and key frames on the selected frame, but on the next frame it will switch back to the previous drawing exposures. I then need to clear all of those exposures. Is there a setting, or a way to set up the library, that will paste the exposures up to the next exposure?


My coworker and I just found out that Pose Copier doesn’t paste if your Default Display is on “Display All.” It has to be on “Display” for it to work. Try it out?
Scene > Default Display > Display

It sounds like a stretch, but hopefully it works out for you!!

Holy smokes! This did the trick for me.

Thank you so much phbadiola!

Did you ever find a solution to it switching back to the previous drawing exposure?