Playing your symbol's nested timeline

Hi folks, I have some flapping wing animation nested within my wing symbol. How do I tell Animate to play said animation on the main stage? It played in my first section until I had the mosquito flip to the other side and I set the animation to start at a new frame (in the Drawing Substitution window). Now it’s just holding on the frame I set it for. Seems like it should be something really easy, but I can’t find a solution anywhere - thanks!

You need to cycle the animation (select the frames of the cycle, then right click on them and select cycle animation however many times you want). Then attach your object to a peg (create the peg and drag all the ways on to it to make them children) then use the animate transform tool (with the little running many selected) to move the object around the scene.

I actually have already created the cycle within my wing symbol and it plays fine for the first 30 frames or so of the scene. it’s when I copied, pasted and flipped frames (my mosquito character turns to face the other direction) from the beginning that the wing symbol stopped playing and holds on the 1st frame. I know things are different from Flash but I’m looking for a function to tell my symbol to play the nested animation.

Since I can’t see exactly what is happening it hard to say.

Make sure you use the animate transform tool and not the drawing transform tool cause that will screw things up.

There isn’t a function, you just set the frames up and create cycle.

There is a flip horizontal option in the animation menu to help with this.

Hmm, the flip horizontal might have been my problem. I actually can’t find that function in the animation menu, however I found it in the drawing menu. and that’s how I flipped everything - ever since then my symbol stopped playing it’s nested timeline. I’m able to change the held frame by changing the “drawing substitution” frame number but it won’t play through. PS Thanks for your suggestions Raider, I appreciate you taking the time to help!

it is a submenu of “flip” in the animation menu

If you can’t find it let me know and i will make a quick video showing you how to get to it.

Using the drawing one during animating will likly cause you problems.

Yes when you’re doing the animation, you need to use the flip available from the animation menu or from the transform tool, not the flip from the select tool. With the transform tool selected, the flip function is available in the tool properties window - the first button under Operations.

Nonetheless, even if the timing is not what you want it to be, you should be able to fix it by simply copying and pasting the frames on the drawing layer. Copy the frames that are one cycle of the wing animation, then do a paste-special on the frames where the cycle stops and it’s just one frame. Now, when you do your paste special, go to the advanced tab and deselect all the keyframing options. Now input a certain number of cycles in the cycles spot, and that should paste back just the drawings, and not affect the animation.

I hope that helps.

Toon Boom Support