Pivot point problem

hi all! First of all, i’m what we call a noob in TBS and i got the v4.5.

I’m doing a movie with 6 scene and i’m block at the scene #3. I’m trying to use pivot point on my cut out animation and nothing work. I’ll explain , I put every part of my character in a individual peg and i regroupe peg into parent child peg. Then i place the pivot point (the green one) at the good spot to make my animation more realistic. When i test the pivot point the element dont turn around my pivot point but around a pivot point that i can’t even see. I really don’t know what to do, i searched a lot of forum and i look almost all video tutorial and i really dont understand! plz someone help me!@


Please have a look at JK’s excellent articles:

or Toon Booms’s:



use the Rotate-Tool (8) to fix the Pivot-point (green) into permanent position before starting to animate, then use the Transform-Tool (7) for animating…


It is important to understand that every peg in a hierarchy has a pivot point. And that every drawing and image element in TBS has an integrated peg included. So if you attach a drawing element to a peg element there are potentially two pivot points that you may need to set, the one for the parent peg element and the one for the integrated peg of the child drawing element itself. It is best not to include separate peg elements in the construction of a cutout character except as the top level parent. It is better to build your hierarchy using the integrated pegs of the various body part drawing elements themselves. This is often confusing if you view older tutorials or cutout characters like Der Der which were created before TBS added integrated pegs in drawing and image elements a feature that was introduced in version 3.5. Let us know if you have additional questions or need more clarification. -JK


i seem to be having a similar problem to this one and it may have to do with the integrated peg system. but i’m still a little confused. i have TBS 4.5 and what you seem to be saying is that i don’t have to attach my cut-out drawing layers to a parent peg and that they are already incorporated. so i should be able to just create one parent peg, say named BOB, then attach all my drawing layers of BOB to it or each other in the parent/ child hierarchy with no additional pegs. right?

the problem i am having…
i have created a worm for my first animation that has a head with eyes and mouth, a scarf in 3 parts, and 7 body segments. i attached each drawing layer to a peg and set-up my peg hierarchy and pivot points (using the rotate tool). but when i tried to move the worm from the position that i had drawn him in to the position that i want him to start at in frame 1 (bottom left corner to bottom right corner) my pivot points exploded all of the screen. literally. some points had moved as far as 18 inches away on the zero zoom and in all directions. some were above, some were below or to either side of the camera view square and almost none were in the camera view. i don’t know what is causing this, but it may have to do with attached peg and integrated peg conflict. also, i have a problem in resetting them. when i try to place the pivot point back to the original position, the image starts to drift from its place. most of the time it is slower than what i am moving the pivot tool, but not always. i have had some instances where the image moved as fast as i was moving the tool, so i could never get there.

so an explanation of the TBS 4.5 peg hierarchy system would be of great help. i think the tutorials i have been reading where based on older versions and with the Der Der character. which has been said to be based on an earlier version in this link of forum posts.

thanks for all the help,
(Ugo/ JK, all your 1000’s of post have helped me tremendously already)

Tip one: peg elements are only needed at the very top of the character hierarchy or if you need to use motion path keyframing. All other character body parts can and should be on either image or drawing elements which can be related through their integrated pegs. Der Der is a perfect example of an out of date character rig that was designed before the addition of integrated pegs.

Tip two: if you are placing a rigged character initially in a scene and not on a motion path, then collapse its top level parent peg first and then move the entire character with the transform tool. Not collapsing the top level parent anytime when operating on the entire character as a whole is not a good idea.

You only want to expand the character for operations where you want to set specific keyframes on specific parts individually.

If you are putting the character on a motion path, attach the character’s collapsed top level peg to another peg element which will contain the motion path. Don’t put motion paths on the charters main parent peg itself. (you can do this but it is a poor practice)

Collapsing and expanding hierarchies at the right times for the right operations is very important. A collapsed hierarchy translates all keyframing as well as other changes down the hierarchy in a ripple effect. While there is no ripple down translation in an expanded hierarchy.

Hopefully this information will give you some additional insight to working with hierarchies. -JK

hey all,
can any one tell me why it is that when i use the rotate tool (and yes, i do mean the rotate tool to set the green pivot) to set my pivot points permanently, that they don’t stay fixed in a permanent position. i keep having to reset my “permanent” pivot points over and over again. then to make matters worse, that after the first initial setting the drawing images start drifting while i am trying to set them again, making it even harder to get them in the right spot and adding the extra work of resetting the image back to it original spot too. this is really becoming an annoyance to deal with seeing how most of my permanent pivot points only stay “permanent” for about 2 or 3 uses.

some kinda fix for this would be greatly appreciated.

There are three potential actions that might be causing you to experience this issue. One is that you are going into drawing view or using the drawing tools to edit a drawing after you set its pivot point. Another is that you are using the scene ops select tool (6) to move your drawing objects in camera view when you should always be using the scene ops transform tool (7). Another possibility is that you are changing (adding or deleting) parent elements into your hierarchy after setting your pivot points.

Tip: You only set your elements’ pivot points after the total hierarcy of elements is constructed. And once you set your pivot points do all your rotational keyframing using only the transform tool (7) and never the rotational tool. Only use the rotational tool to set the pivot points location.

Tip: If during keyframing while using the transform tool (7) you see that the blue pivot point is not where you set the green pivot point then select the rotational tool and the green pivot point’s display will be refreshed, you don’t have to or want to move the green pivot point after starting your keyframing as that creates unexpected changes in all your previous keyframe settings which were relative to the original pivot point setting.
Once you just refresh the setting’s display by selecting the rotational tool, select the transform tool (7) and resume keyframing.

Also if you are using the old work-flow in the current version of TBS (IE the Der Der approach of using peg elements on top of drawing elements, see my previous post above) then there are two pivot points that influence each drawing element and you want to be sure they are set identically to avoid confusion if you select the peg element or if you select the peg elements child drawing element. Another reason to avoid the Der Der approach to rigging.

From my experience it is usually some action inadvertently done while working on keyframe animation that might cause what you describe. It is not, again in my experience, a problem in TBS itself. -JK

i am still having the floating pivot points problem…

i have completely drawn out my character.

i have completely set the hierarchy using the integrated pegs.

i am only using the rotate tool to set the pivot points.

i am only using the transform tool to manipulate my character.

i have tried refreshing them with the rotate tool, but they don’t go back.

what i don’t know is how to explain this any better, as far as i can tell, i am doing things the right way, but as soon as i start to move a character my pivot points start to drift.

i can’t get past the beginning of my animation because of this. they start drifting immediately and the only way i can seem to fix them is to start over. how can i fix the problem if i get past a certain point and they drift without me catching it. sometimes it is really hard to notice with a 1/4 size screen and 1/2 quality graphics. plus my character is coming out from behind a clipping mask in the beginning, so i can’t even see the whole character.


Nolan ? Ugo ? anyone? please jump in here. I can’t duplicate this problem and we can’t seem to isolate how mstaur is working that would be causing his pivot points to float. HELP ???


If you have set your character rig with pegs the very first thing to do before you start to set your pivot or animate is to trigger the peg only mode on (Tools>Turn Peg Only Mode On). What is possibly happening here is that you set your hierarchy up and when you started setting up your pivot when you selected the element through the camera view the pivot where actually set up for the drawing element rather then the peg. Then later on if you click on the peg you end up rotating with the wrong pivot or when you click on the element you will notice your peg start to turn around for some reason.

Not sure if that is what you are experiencing but in any case for rigs made with pegs this option is quite necessary. If you need to modify the drawing itself afterward you can either turn the option off or select the drawing element through the timeline.

Else then that we would need to have a sample of your scene to see what is going on I guess.



OK, this is really getting F#@%!^G old,

i have been working on this floating pivot points problem all day and i still can’t get it fixed. i have tried completely scraping my old character thinking it was a residual effect from setting it up in the old (der der) rigging system at first and built a new character from scratch. i started with all new drawing elements, set their hierarchy on a parent “character” peg, turned on peg only mode, used the rotate tool to set the pivot points and then tried to animate them, only to have the same effect. i have read the users manual on how to animate a character and i am doing it the way it says to do it. i don’t know what else to say… i can’t seem to move a part more than once without having to reset the pivots.

my character peg hierarchy looks like this…

(parent peg) worm
(Drawing Image) worm neck
(DI) worm head
(DI) worm pupils
(DI) worm eyelids
(DI) worm mouth
(DI) scarf
(DI) scarf end 1
(DI) scarf end 2
(DI) worm [body segment] seg 1
(DI) worm seg 2
(DI) worm seg 3
(DI) worm seg 4
(DI) worm seg 5
(DI) worm tail

i am wondering if it has something to do with the worm set up, especially in the body segments. i did open up a new application today and set up a stick figure man. (maybe i should do this with a worm) i was able to set pivots and animate him flipping head over heels across an arched movement path, moving arms and legs however i wished at any keyframe position with no problems. nothing detached itself or operated in an unexpected manner. i didn’t have to reset any pivots after the first time. from what seems to be happening is that the worms body starts to disconnect rather than the head, but i’m not sure about this part, its a recent realization.


Don’t let it get you down, keep experimenting and trying different approaches and eventually you will find a rig that works for your worm. The best part is that you might also learn some important new skills that eventually will make your animation work easier.-JK


I would probably move both the Worm head and the scarf under the body element so the everything is linked to a physically visible element in the scene (therefore if you move your body the head and scarf will move along too). You might need to nudge the head and scarf in Z above the body but that should be pretty much it.

Still keep your Parent Peg to use it as a displacement peg (if you want to move the element in the scene use that peg). Hopefully this will do the trick.

Best regards,



i don’t know what the difference is but i did draw another (stick figure) worm in another app. except for the facial features, it was the same. i was able to draw, set up the hierarchy and place pivots and animate it crawling across the screen in a 100 frames without any problems (and in mere minutes as a side note). i don’t know why it would work in one app and not in another. is it possible that there could be conflict between my worm character and some other element in my animation? my experiment had only the worm… my animation has another bird character, 5 background elements, sound track, and a clipping mask so the worm can crawl out of a hole in the beginning. any ideas would be welcome.


this is a link to my broken worm video i posted on youtube, so you can have a bit of a visual to look at.


and a link to my experimental worm if you want to see the difference.


I think the reason the worm explode is because there are transformation done on the element before you set the pivot points. Try to select everything on your scene with the worm and do a Reset Transformation. Then if you have to move parts around make sure to use the the Select tool rather then the transform too.



hey ugo,

i have used the timeline to select all parts of the worm, but i can’t find the Reset Transformation option anywhere. can you tell me where it is at? and just for further clarification which select tool, the drawing select or the layer select.



I got a little confused between the different naming of the function we have in our software. The option you should use is Remove All Keyframe. This will also reset the position of the element.




i have reset all keyframes before and just did it again, but to no avail. when i first reset all the pivots, they work just fine the first time. as soon as i go back a second time they are in a different place.

before i start to animate i can move the character all around using the transform tool, but once i place it in the scene and start to use the motion tool to move the character peg forward through the scene, the body starts to come apart as i set its individual elements.

i have also noticed that if i set a position for an element and then have to go back and reset it because the first position was not right, the pivot has usually changed.

the only other thing i can think of is that when i had originally drawn the character it is bigger than what i could fit in the scene properly, so i had to scale it down. i have used the transform tool and the scale tool to see which one would work better, but they both had the same effect.

thanks for all the efforts done so far,


I think that at this point the best way for us to figure out what is going on would be to get an actual sample project or template of the character for us to decrypt the issue. There might be something we are currently overlooking at the moment.



hi ugo,
how would you like me to send it to you. can i just attach it to an email and use the link on your forum posts?

i have 3 versions to look at. i have the original that i saved before i started to animate. so all the pivots are where they are suppose to be, but no animation is done. then i have a second one that i have been messing around with trying to figure out what went wrong. it has a about 20 frames demonstrating what my pivot problem is. and yesterday i started on a whole new version. i was starting to think that maybe because i had started out using the old rigging style that maybe something was left behind that was causing the problems. not so sure that is the case now. i redrew all the backgrounds and the worm and just tried moving it across the screen with the camera panning on it. at first i had the same problem. then i found the “keep proportions” check box. at first it kept everything together, but then they all became unchecked by themselves and everything went back to the same pivot problem. while trying to figure out what happened with the check boxes, everything started working like it is suppose to, but i don’t know what i did. and that is the answer i am really looking for… what did i do to make it work this time?

thanks for the help