Pieces disappearing

Question from a Toon Boom Pro newbie here - I’ve been following along with the tutorials and they’ve been quite thorough and helpful with the whole process, but I ran into a bit of a problem. For some reason my character (which I was attempting to puppet rig) is having troubles being saved as a symbol. I followed along pretty much exactly what was happening in the tutorials (changed slightly because the character is a different shape of course, but the gist of it I thought was the same) - but when I went to create a symbol from it, it was missing its eyes and the head layer was showing up weird, as you can see in the preview mode:
Not sure why it automatically calls it “fox neck”, i do select everything on the stage, not just the neck.

I tried duplicating it and then using that but it didn’t work either. I’ve seen a couple of things online regarding this but nothing seemed to have a definite answer. I thought I could work around it, but now as I’m working with things in perspective, it keeps coming up like this.

I’m not sure what I’m doing wrong or how I can fix it, and I don’t want to start over…

Sorry if this is a silly question. Thank you for any and all help!

First of all if you want to do a rig I would not create a symbol because a symbol resides only in the present scene. If you want to reuse your character in another scene you should create a template not a symbol.

Second the name given to a symbol or template (tpl) is the name of the first element at the top of your Timeline. Since there are many layers to your rig it suggest that name but you can always rename it anything you want.

Third, does that character look like that in the render? I would think not. I think maybe your character has some layers behind the background image. Maybe you did some Z change in the character so the head is actually behind the Bg. Try moving you image a further in Z.

Thanks for your help! This is probably a dumb question, but how do you create a template? For this particular character, I wanted to make it a template and I had it in its own scene, but as I said, every time I tried to add it to the library, the facial features would disappear so I tried just working with it as the whole scene…

On the third point - I hadn’t worked at all with the 3D aspects when it was giving me this problem, and I checked the pieces in the files and the Z values are all the same. It just keeps those values locked in that position no matter if i copy and paste the whole character (selecting all) or try to move the character or add it to the library or anything.

Sorry for asking silly questions, I am just so lost!

The templates are created in a similar way to the symbols except that you drop your elements in the other folders in the Library. Notice that you have the folder Symbol and the other ones below. The other ones are folders on your machine. I’m not sure if you have Animate Pro or Harmony but you might have to Get the rights to those folders. You can right-click on them and Get Right to Modify to remove the padlock if there is one. Then just drag and drop as for symbols or copy/paste from the network. You should check the Help for Templates if you want more info.

For a master rig of your character it’s always better to select every modules or group pertaining to it in the network and copy/paste into the library. If you copy/paste from the Timeline you will not bring the Composites, groups or special connections to Composites that you see in the Network since the Timeline doesn’t display them.

As for the textures not showing like in your images it might be because you are in the Perspective view and I can see that you are not facing straight on. If you look in the Camera view in OpenGl and in Render mode do you see every thing? If they look ok in the render and in OpenGL then it might just be a graphic card display issue in the Perspective view. Nothing to worry about then because the final render will be fine. I’ve seen sometimes some display issues in the Perspective view, some elements showing transparent as you rotate your view in 3D. But again it’s not in the final render.

I have a similar problem. I’m currently rigging my character so that it could be made into a template. But when I would scrub through the layers, pieces would disappear from the different perspectives. For example the head would be in the front perspective but then would disappear in the three quarters perspective. I named all of the drawing objects, but when I look at the drawing substitution thumbnail, it’s blank. It occurred before, so I just manually redid the layers so that there would be a drawing in the layer. But I feel like there must be a simpler solution.

When rigging a multi-view character template, make sure that you have set keyframes on all the layers on all the frames where you have a new pose. When you have a new pose, if you are using z-depth nudges, you need to have a keyframe on all poses so that those z-depth changes are keyframed.

You can just collapse all the layers under your master and put the keyframe on there and it will put the keyframe on all layers.

Other than that, when you are looking at the preview in the preview window, it is just calculating a preview so if you want to check out what the actual template looks like, then you can right-click on the template and do an Edit Template. This will pop open the template so you can see what it looks like inside. If all looks good, you can close it to go back to your main scene. If not, you can either make adjustments here, or you can go back to your main scene, delete the bad template, and make a new one after making the adjustments in your main scene.