Permanently placing pivot point on a pegged puppet

When I say pivot point, I mean the blue dot. I imported my layers from AI, saved it as a template. I open a new project to futz around w/ the puppet. I am able to permanently change the pivot on all the limbs, etc., but when I select a frame from the master peg layers, the blue dot pivot is WAY over to the right. When I select the pivot tool, it almost randomly selects a puppet part that I’ve already set.

I can temporarily change the pivot point, but that’s annoying b/c it’s so far off to the right, I have to use the hand tool every time to select it.

Any ideas?

Can it be that you might have the “set pivot for symbol on all frames” option selected? When you select the pivot tool, look in the properties and make sure the “set pivot for symbol on all frames” is not selected.

Then set your pivots.