Pen Misalignment With 2 Monitor Set-up

Hi. I am getting major misalignment with the pen in Harmony and it appears to have something to do with my 2 monitor set-up. I have a PC laptop hooked up to a Yiynova Tablet. I have the tablet set to be my primary monitor with the Extend displays option on. When I use Harmony, the first line I draw is correct but then every other line I draw afterwords is about 4 inches to the left. If I go into my display options and turn off the display on my laptop, the alignment on the tablet is fine. I really need both monitors on to work though. I have the most up to date drivers for both my tablet and my GPU. Other programs like Photoshop don’t have this problem. Does anyone know how to fix this? Any help would be appreciated.


I have reinstalled the drivers multiple times. It’s when I set it to the Extend Desktop option that I have the problem in the first place.


Did you solve the problem meanwhile? Something similar to what you describe could happen when the tablet screen has a scale different of 100%. It might work on Photoshop or other software but not on Harmony. Did you check that?

Luis Canau

If you run harmony as an administrator it will fix the coordinate issue in dual monitor display, same for storyboard pro. But pressure is gone … still trying to figure out why.

Please note I only tested this in harmony 14 and storyboardpro 4.2 using a yiynova msp19u.

What Icanau is referring to is setting a custom scaling level instead of letting windows screw it up for you.

To do that right click on your desktop - display settings - advanced display settings - advanced sizing of text and other items - there a paragraph under change size of items, click on the link that reads set a custom scaling level, simply change the scale percentage to 100%.

That should do it for both monitors unless your graphics cards settings are set to override these settings which I doubt would be the case.

This did not solve anything but I think it is worth sething to 100% in case a fix comes along

Sorry, when you say 100% do you mean the resolution of the screen on the tablet? If so, yes it’s set to it’s native resolution of 1440x900.

At least with Wacom tablets you can set up a tablet rectangle to represent something other than an exact match with the monitor area, referencing full area, a portion of the area or multiple monitor coverage. I have mine set up so less tablet area represents the monitor area so that less pen movement is required to navigate the screen. In Preferences I have Screen Area: Full and Tablet Area: Portion.

I didn’t mean the screen resolution, but the scale of the tablet screen. Windows might guess and select by default a “recommended” zoom level, for instance, 125%. That setting would be somewhere under ‘Display’ on Control Panel. That could override your native display resolution and mess with the lines you draw on the tablet. You should have both screens with 100%.

Which operating system are you using?

Luis Canau

Large software vendors like Adobe make their own custom tablet drivers.
You can try setting the monitor setup to Extend Desktop (AKA Horizontal
Span). Beyond that delete all tablet drivers and settings from the system.
Reboot and re-install the latest driver for the Yiynova (this tablet is not really
supported and may have some issues).

I tried all of the suggested ways to make this work with my 22HD Touch Cintiq display which is connected to my PC along with 32" Benq monitor and the only program where I have such issues is Harmony. The latest version, latest drivers, Windows 10 with all latest updates. I know this shouldn’t be an issue over the 4 years now when we talk about a few thousand dollars hardware and not so cheap software. Get your s tuff together guys!

Did you try deleting all of your wacom preferences in the Wacom Tablet Preference File Utility? A lot of problems are created when installing new driver versions and this sometimes fix them.
Also, try installing the last stable driver, for each version, Wacom releases a number of revisions (6.30.1, 6.30.2… etc), try installing the last revision from the previous version (if 6.30.x is the current version, try installing the last revision for 6.29.x)

You can find a history of the Wacom Drivers here:

Hope it helps, those problems are extremely annoying.