Peg Pivot Point Won't Stay in Place relative to Art layer

Using Harmony Essentials 12

My pivot point changes location between keyframes despite using Rotate Tool to setup Pivot Point location.

Steps I’m using:
1 - Set pivot point on art layer using Advanced Animation Rotate Tool while Animate is off
2 - Set pivot point on art parent peg layer using Advanced Animation Rotate Tool while Animate is off
3 - Extend art layer
4 - Turn on Animate
4 - Create keyframe and use Transform tool to move parent peg position

Video example of issue (temporary file location):
http://www.sd43.bc.ca/secondary/centennial/PivotPointQTemp/PivotQuestion.html

Anyone see what I’m doing wrong?

Thanks,
Lisa

If you’re animating with pegs, it’s better to use use only the pivot on the peg. That might be the issue. On the drawing Layer Properties select, below on Drawing Pivot, the option Apply Embedded Pivot on Parent Peg. That way you can select the drawing and when you animate all transformation will be made on the peg layer avoiding keyframing both layers.


Luis Canau

Thanks Luis.

I actually did start the process with only moving the pivot on the peg as tutorials seemed to indicate that was all that was necessary. However when that didn’t work I changed how I do it and started with moving the pivot on the art layer and also the peg.

In “Layer Properties” there is no “below”. There is only a transformation tab and the Pivot group only has Axis(X) and Axis(Y) options (separate rather than 3D is chosen).

We are using Harmony Essentials 12.x

did you set the pivot points with the Translate Tool? it’s next to the Rotation Tool, it seems to work the best for setting the position for a pivot or rotation point, use the Transform Tool to Animate, and if you want to change the position of a drawing without making keyframes deselect Animate above Transform Tool

Thanks for the reply.

Unfortunately setting pivot points with the transform tool (animate off) actually yielded worse results for me. When creating keyframes the pivot point moved even further than before with using Rotate.

Eureka!

In setting up the scene I had moved the “ball” to a different depth from the camera.

When I added a peg, it was not at the same depth as the art layer.

I just reset the x,y scale for both the art layer and the peg to 1 and then set the z position for both the peg and the art layer to 0 and it worked.

Now the pivot point stays in place. Problem solved.

Ah, I see, Essentials doesn’t have the ‘use embedded pivots’ option. It’s tricky when you don’t notice you’re applying values to both elements and pegs, especially with the Z axis. Good you solved it.


Luis Canau