Peg Hirearchy Cycles


I am currently working on a cut out animation using toonboom studio.

I have all my separate layers such as forearm, arm, hand etc into a peg Hierarchy which is working great.

However, I have just made a walk cycle and realised i can’t seem to cycle it. The main reason because they are not individual drawings set onto one Peg.

They are one drawing (eg arm) set to there own individual Peg.

Does anyone know a simple solution around this?

Thanks you.

If you have not already done so, you want to attach your entire peg hierarchy to a top level main peg. Then you can collapse that main peg and select the frame sequence that covers your cycle. Copy that sequence. Then move to the end of your cycle and use paste special to paste the cycle. Then move to the end of that instance of the cycle and use paste special again to paste the next instance of the cycle and repeat this for each desired looping instance. You then will want to attach your character’s main peg to another peg where you will animate the forward motion of your walk separate from the actual cycle.

Check out this series for some insight. -JK


Thats fantastic thank you, before I had tried looping with no effect. The past speacial is perfect.

Also whilst I am here. When I turn on the Peg Mode Only (M)…I lose my automatic key framing…so if I go to frame 24 in my timeline then move my legs in to the position I wish. It does not seem to set the keyframe automatically anymore?

is there a reason for this?

There was a significant change operationally in TBS between version 3.0 and version 3.5. That change was the addition of integrated peg elements into drawing and image elements. Prior to version 3.5 those types of elements didn’t include pegs and therefore had to be attached to peg elements. The peg only mode was originally created to make keyframing easy by not allowing the user to select non-peg elements when they were making selections in camera view directly for the purposes of keyframing. That protection is not really appropriate in the world of integrated pegs. So if you are trying to select a drawing element directly in camera view with peg only mode on TBS won’t select that element but rather the next actual peg element in the hierarchy if there is one. If you have no actual peg elements in your hierarchy then peg only mode doesn’t let you select your drawing or image elements for keyframing in camera view. So there are two solution approaches the first is don’t turn on peg only mode if your hierarchy has no actual peg element included or include at least one actual peg element in your hierarchy. -JK

I understand that yes, my character has a peg for every element of its body.

The problem is that when I select the parts in the drawing view (in scene planning mode) i used to be able to automatically set a key frame when I let go of the peg position in the drawing view. For some reason it does not work now.

Do you know why?

Are you in camera view or drawing view? You can’t keyframe in drawing view. You have to switch to camera view. -JK

It seems to be working now, I am not sure how I solved it though.

I loaded the default scene planning work space and then selected fram one in my timeline and then selected the Camera View Panel on my MAC and the selected my characters arm in Peg Mode (M) and it seemed to place a key frame when I released the mouse. So it now seems to be working.

Thank you for replying, much appreciated.