Paint Delay - Normal?

I’m using the PLE to decide if I should purchase the full deal. I open a new project on my Vaio laptop (4Gig RAM, 64bit Vista), and then selecting the paintbrush I begin drawing. Only after I let up on the mouse button does it actually execute the drawing…so if I click and move around I get nothing until I stop and let off the button, then I get a nice surprise when I see what I drew.

Is this normal? If so I guess that’s it for me and Toon Boom, but I have to believe this is not how it was designed…am I doing something wrong?

EDIT: Note that based on some other posts, I took Aero off the mouse - no change. Could be that it just doesn’t work with this machine…bummer, but it’s good that they put the PLE out or I’d have been annoyed to spend all that money for software that won’t run on my fairly new and nice hardware, so that’s the bright side.

EDIT #2: Switching to my Intuos 4 the problem still occurs, but seems less bad…little flicks seem to draw instantly, but attempting a wave has the same issue…draw, then POP you get the line after you stop.

EDIT #3: Now I get an “R6025 - Pure Virtual Function Call” Visual C++ Runtime Library error frequently when starting a new file. According to some Microsoft tech documents, this indicates that this particular issue isn’t with my machine, but it is (their words) “a programming error” (kb125749)…is this fixed in the non-PLE?

How to reproduce on my machine - - open the program, draw some things, choose File/New, and then click on “Don’t Save” - kills it 100% of the time with the R6025

:frowning:

Have you turned off anti-aliasing in the preferences? Preferences→OpenGL→Real-Time Antialiasing and deselect the Enable box which is turned on by default.

When I was working with the PLE version I had a lot of trouble with the program crashing, errors etc but now I use the full version of Animate Pro and I find it’s really stable. I’m working on a Mac though, not on a PC.

I will give that a try - my concern though is that the kb at Microsoft specifically calls this essentially a bad bit of programming, and I’m also worried that the PLE is substantially different than the ‘real’ product, because it means I can’t use it to evaluate whether or not it works (or works on my hardware).

EDIT: Turning off this anti-aliasing doesn’t change how the mouse works - still sits and then pops it in once the stroke is done.

We just brought a Acer Aspire Z series touch screen computer running Windows 7 to the studio for testing. The big touch screen is wonderful, and has great potential for drawing using Animate Pro. However, we have exactly the same problem as you do, but in Animate Pro; i.e. you must draw the complete line and lift the pen before it registers. In Windows Paint the line does progress as you draw which is the norm.

There appears to be a tablet driver already installed that will not allow the installation of a Wacom tablet driver. You do not seem to need the Wacom driver. But somebody has to fix the software in Animate Pro to recognize the Windows 7 default driver! We feel that the problem is related to Windows 7 and its drivers’ interface with Toonboom.

Certainly possible, but I’m using Vista 64 - if it runs the same way then it could be the same issue you’re seeing with Win7.

I’m may actually be more concerned about the C++ error, because that seems to indicate not just a lack of compatibility with my one hardware config., but a problem with how they’ve structured the program - unless Microsoft is wrong and this error can also come up for reasons other than bad programming.

Either way, unless I hear some official statement of the differences and guarantee that the errors are PLE only, I can’t really buy. I doubt they have a policy that allows a return if I order it and it turns out that the problem is still there.

Maybe give this a try. This is what lillyV suggested in another topic here:
http://www.toonboom.com/support/forums/animate/index.php?board=15;action=display;threadid=1505

"If you still have a problem, try to update the drivers for your tablets. Sometimes it has been reported that people who have multiple drivers, for example for your Cintiq and your Intuos 3, have had the drivers interfere with each other. I would recommend deleting the preferences using your tablet utility, then delete the drivers and install only the driver that you use the most often."

Maybe if you deleted the prefs, then the Windows driver for the tablet and installed wacom’s driver instead?

I hope you get it resolved!

I have tried both suggestions, (1) turning off the aero scheme for the mouse and (2) downloading the latest driver for the tablet… which was just twelve days old as of today. Unfortunately neither approach solved the basic problem which is that nothing draws on the screen until after the pen has been lifted at the end of the user’s stroke (either as drawn on the tablet or when a pen is applied directly to the touch screen).
Any other ideas?

Ignoring the C++ crash for a moment…I’m not a developer, but I have a hard time blaming Aero or tablet drivers when this behavior (on my system at least) is present for both mouse AND Intuos.

It seems like some of the suggestions about Aero and drivers is related to OFFSETS, also…you make a stroke on your tablet and the resulting line is shifted (left, right, up, down)…my problem seems to be a case where the resulting line is exactly what you drew, you just can’t see it until you release, so it’s impossible to work with.

Perhaps it’s because you’re on a 64 bit system? There might be some bugs to be worked out on Toon Booms end because Animate Pro is only certified for 32 bits.

Yeah, well it’s kind of a lousy situation. They SAY that version 2 is compatible with 64 bit, but if v1 is NOT, then I’ve got no way to try it before I buy it.

So there remains the possibility that it will be just as buggy when v2 comes out and it isn’t really 64bit ready…

that might be too cynical, but the point remains that I’ve got no way of knowing if this product is any good for me without buying it first? I can’t really wipe out my PC and install a new operating system just to see if this will work.

This is a bad year to be telling me that I should buy into something so that I can find out what’s in it.

Do they have a beta that I can use long enough to see if it works?

EDIT: I also see threads where it seems like the TB rep is saying that v1 DOES work in 64bit Vista, but not 64 bit XP…I think that they should extend the promotional pricing until those of us on 64bit can actually see if this thing works.

I have now loaded Flash on our new “test” computer (described above). I am happy to report that drawing in Flash is normal and lines appear on the screen as the pen moves. It is only within Animate Pro that there is a drawing problem, that is: a delay in showing the line drawn until after the pen is lifted at the end of each stroke. The problem is consistently there, whether one tries to draw using a tablet or draws directly on the touch screen itself.

We run Animate Pro on several 64 bit machines here. We do not know if it takes advantage of 64 bit technology but, whatever the case, the program itself runs fine. It would seem that the difficulty we are encountering on this new computer has to do with a conflict between Animate Pro and the computer’s “Windows 7” operating system (which we have no where else in our studio at the moment).

Well, on my 64bit Vista (NOT Windows 7) machine the problems are there - both the drawing issue and the crashes / programming error. I have found no way of executing the program or changing the preferences that fixes it.

I guess I have to decide if I want to save $150 by flying completely blind - buying software that is completely unusable in my current environment…in the HOPES that the next version is actually compatible. Sort of beginning my relationship with this company with the complete opposite of the warm fuzzies.

I guess I’ll take the stance that no matter what their own policies are, if May comes around and V2 of this thing doesn’t work on my machine which meets their required specs, I’ll expect a full refund. Standard implied warranties still apply to software in my state, and I have claims from the company that it WILL work, so hopefully their good folks.

Off to see if there are worthwhile competitors to this product anywhere that are capable of running in 64bit.

you using a video card or is the processor doing all of the work on your Vaio?

The Vaio’s a laptop - no fancy graphics card, but it easily handles 3dsMax, and I just got done rendering a scene in Vue 7 that had over 3 billion polygons, while simultaneoulsy editing images in Photoshop.

If 2d animation with TBA is that taxing on a processor, something’s gone horribly wrong.

Brenda - - try this:

Go into the PROPERTIES for your TBA shortcut, and change the settings for Compatibility to Windows XP SP2, and then click the box that disables “Desktop Composition”…don’t change anything else.

I don’t know if it will eliminate the error/crashing, but it seems to make my paint strokes actually occur in real time.

EDIT: The brush strokes seem to work, but it still crashes to desktop if you try to open a new project and say "Don’t Save’ to the old. This gives you no details, just dies.

If you instead create NEW, give it a name, and tell it to save the old, then you get the runtime error with the illegal/bad programming function call.

But at least I can draw, so maybe I can see some features.

What is the graphics/video card in your Vaio? I think what mdhender was getting at is there seems to be issues with many users if their card isn’t compatible with Toon Boom.

If you have an integrated graphics chipset for example and not a discrete card compatible with OpenGL it might explain some of your problems.

What are your full specs on your laptop?

Here you go:

Processor
Type: Intel® Core™ 2 Duo Processor T6400
Speed: 2.0GHz
Front Side Bus Speed: 800MHz
L2 Cache: 2MB
Technology: Intel® Centrino® processor technology
Memory
Type: DDR2
Installed: 4GB PC2-6400 (2GBx2)
Speed: 800MHz


Graphics
Processor: Mobile Intel® Graphics Media Accelerator 4500MHD with
Intel® Clear Video Technology. Total Available Graphics Memory:
1750MB (max.)
Chipset: Mobile Intel® GM45 Express Chipset
Max. External Resolution via VGA: 2048x1536

JT

I know there have been other users that have had problems with that integrated intel chipset.

Here is one post made back in late January:

http://www.toonboom.com/support/forums/animate/index.php?board=16;action=display;threadid=1411;start=msg6051#msg6051


Maybe Lilly has some new info on any updates with Animate 2.0 and the intel chipsets?

Having played around in graphics since the 1980s, I remain amazed that we still have all this fiddly, house of cards nonsense when it comes to software and hardware. Wouldn’t it be cool if we had a situation where hardware approved for an OS would run any software compatible with that OS?

So it sounds like TBA is out of my normal workflow. This machine runs 3dsmax and Vue like a dream, Vegas, Photoshop…anything else I throw at it. If I didn’t have 99% of my apps running flawlessly, I’d be more willing to give TBA some slack…

…maybe version 2 will actually work with my hardware.

I know what you mean and how you feel. At one point I had the opportunity to buy Apple’s Motion, before they bundled it with their Final Cut Pro suite, but ended up passing because my mac and its graphics card wouldn’t run it.

Right or wrong I think more and more companies are going to be putting more emphasis on having graphic cards do more of the heavy lifting. I can understand it. Many people want real time effects, want to view things in real time. Want things to be fast and instantaneous. The only way to do that is to make use of the power of GPUs.