Option 'Stop-Motion Keyframes'?

The option ‘Stop-Motion Keyframes’ doesn’t seem to work: my keyframes always end up as motion keyframes?

Seconding this. This is the case for my Animate Pro 2 as well.

Works fine for me. Did you change the Preference> General tab> Stop-motion keyframes?

All new keyframes will follow that setting. It will not convert existing ones though.

If you want to convert existing ones you have to select them in the Timeline and Press the Stop motion icon or if you want to do the whole layer you can right-click in the left side of the Timeline and choose Stop-motion keyframes.



I changed the preference, it doesn’t seem to work.

For me I can click on the icon or through the menu like in the image attached and it works.


http://img820.imageshack.us/img820/4606/screenshot004ask.jpg

Maybe you can attached an image of your timeline so that I can see what it looks like.



That is not the problem: checking the relevant preference doesn’t seem to work…

Ok, so check the preference > ok> reopen preference > is it still in the same state?

If yes try a restart the application which you probably have done but just to make sure.

So now if you add new keyframes (F6) they are not in the right state?

Hum, I’m on Windows, are you on mac? I don’t have a mac with AP2 here. I wonder if that could be a difference, I doupt it but…

Are doing it on a single layer or on a collapsed group or rig?

I figured it out, it all depends on the order in which keyframes are added:
A keyframe after a motion keyframe will always be a motion keyframe, ignoring the preferred setting
A keyframe before a motion keyframe will follow the Preferences

(working on os x)

Yea. That’s right. The state of the keyframe mode (stop or not-stop) affects only what comes after it.