openGL refresh stuck

I have Harmony 14 running on a Surface Pro 4 i5 with 8GB ram. When scrubbing in the timeline, the OpenGL camera view remains stuck on the first frame. How can I get it to update properly to the current frame on the timeline?

Can you post a screen shot of your Timeline content?

It’s for a TV show under an NDA so I probably shouldn’t post shots of the characters. But just the timeline content looks like this.

The timeline is on frame 35, but the camera view is still showing frame 1.

I understand the NDA. I wish I could see everything on your screen. You never know what might be noticed from an objective perspective.

I see you have multiple cameras. Taking a stab in the dark, is it possible that you are using the wrong camera?

Does everything render properly?

Yep, and the same scene works properly on my desktop computer. I am just trying to get a portable setup going. I think there is a bug with the Surface Pro’s graphic card which makes the OpenGL not work properly.

Sometimes the camera view does update, but only for one frame and then sticks there when scrubbing over earlier ones. When switching between render view and open GL, the camera view updates to the appropriate frame and then sticks there.

Have you tested whether unchecking Full Screen Aliasing and disabling effects in preferences makes any difference?

Yea, Full Screen Aliasing was always unchecked, but I turned it on just to see what would happen and it doesn’t make a difference. I’ve also tried just about all the combinations of effects in preferences with no effect. Also a few different values for OpenGL playback cache, and turning off and on ‘enable graphics card acceleration’.

I also tried installing the updated Intel graphics driver, which is slightly different than the automatic windows update version, but no help here.

You’d have to really contract toonboom support and send them the file (they can work with NDA files). My guess is on heavy render scenes perhaphs it runs out of gpu memory too fast so it cant scrub like with the portable you have.

It’s a good guess. I made a new scene with a simple box moving around, and have the same issue, so it must be something else. I contacted Toonboom support. Will post back here if we figure it out.

I went and reinstalled Windows and the problem fixed itself.

Tech support suggested the issue was that the latest driver for the Surface Pro 4’s Intel video card breaks OpenGL in Harmony. The working version I have installed is and its date says 3/9/2017. I’ll make sure windows update doesn’t replace it.