Open GL Matte Renders

When I render with anything I get black for the transparency, even with + colors. Someone told me that this is how the program works. I want to use the matte in the Open GL view to composite with in After Effects. When I do any render with Open GL as frames or movie, with or without matte on, I get nothing but black even when it shows something in the camera view with GL turned on. I’m stuck and any help is appreciated!

are you using standard or pro?

are you trying to export the matte is what your saying?

If you just want a character over a blank background, then you can render frames via the network using an image type that supports alpha channels. Try saving them in TGA4 format. That will save the character and the alpha channel in one file.

Thanks for the responses!

I guess I am still confused as to why tiffs show black where the alpha should be. What are the formats that will export from Toon Boom Pro with a clear alpha? I wouldn’t worry about exporting a matte if I could get a clean alpha.

Dear Lilly,

Please help me. I have a simple animation which I want to export to .png images (frames) with transparent backgrounds. But I can not find the Transparency Type settings! :frowning:

(I have now changed from the standard version of Toon Boom Animate in the Toon Boom PRO version.

Thanks for your help! :slight_smile:

Transparency Type = Colour Mode (Export window - TB Animate Standard )

Dear Anybody please help me! :’( I’m newbie in Toom Boom Pro and I don’t know how to export picture with transparent background. In the standard edition of Toon Boom Animate was an option (Color Mode: Color with Alpha) in the export windows, where I can set the transparent background for the images. But in the Toom Boom Pro version I could not find the Color Mode option in the export window of OpenGL frames rendering or Network rendering.

My question is How to export images (any format) with transparent background?

I found the solution! :smiley:

In the Network window, you must click on the Write Module Properties Icon (little yellow square). Then the layer properties window pops up. Here you can configure the output image format (Drawing Type drop-down) is PNG. When you’re finished, click the Edit menu and choose Preferences. The Network tab, you will find a drop-down menu that is called Transparency Type. Here you can select the “Clamp Colour to Alpha”.

I hope help for you! :wink:

Merci madame! :wink:

I think you want to export frames instead of OpenGL, because the OpenGL render is just a preview render and is not made for the purpose of creating final renders for mattes and the such.

Do a File > Export > Images (Animate) or a File > Export > Render Network (Animate Pro).

If you’re using Animate Pro, and you want to export multiple layers so that you can composite them in After Effects, then you can render them by putting multiple write nodes, then when you do a Render Network it will render each write node simultaneously.

I hope this helps.


It kind of depends on what program you’re viewing the images in. All of TGA4, PNG4, PSDDP4 will have an Alpha channel that contains your matte information in it automatically. I’m working on a Mac and when I open up these images in Preview, all three of them appear to have a transparent background - because Preview properly interprets the alpha animation and so I don’t see any black.

If I import the images into Photoshop, however, then both the PSDDP4 and the TGA4 appear to have a black background, and only the PNG4 properly interprets the alpha channel. I think it has something to do with the way that when Photoshop creates a file, it’s not just transparent to begin with, you have to delete the “Background” layer before you can create transparent images. So in Photoshop to get the alpha, you would go to the Channels tab then Cmd+Click (Mac) or Ctrl+Click (Win) to select your alpha, then you can go back to your RGB channel inverse the selection and delete.

Now when I did my test in After Effects, all 3 image formats interpreted correctly. Just make sure that you set the Alpha to Straight and it will automatically use the alpha channel to make the black transparent - there’s no need to get rid of the black.


Also just to add if you want to export an image that contains an alpha channel, from the yellow options box in the Write node you want to select something like TGA4, PNG4, PSDDP4, anything that has a 4 at the end - this means for channels - 3 for colour, and one for transparency, or RGBA.