Onion skin without underlay?

I am playing with paperless animation in Animate Pro, doing rough sketches in the Underlay Art, cleanup in Line Art, inbetweening using the onion skin. However, I just discovered that the onion skin includes the Underlay, which makes it hard, if not impossible, to inbetween. Is there any option to hide the Underlay in the Onion skin, as can be done in the Drawing View?

I am working in the drawing view, but when I use the onion skin, it includes the underlay art, even if I do not see it without onion skin.

Let’s see if we can get this sorted out, maybe I’m just overlooking something. I created a frame with text “line art” in the line art layer, and “underlay art” in the underlay layer:


In the next frame, both texts are visible in the onion skin, whether “line art” or “underlay art” is made visible or not.


As I see it, the onion skin should respect the visibility settings for line/underlay art. Any clue?

This is getting interesting, you are doing more or less the same as I, but with different results. My screenshots are

The screenshots are

I tried to replicate your experiment, with different result:

Your results are exactly what I expect, and different from mine.
I am using Toon Boom Animate Pro 2, Version 7.9.1 (6016) for Os X 10.7.3

I have been able to replicate this behaviour at school, which makes it hard to believe it is some glitch on my computer (although we can never rule this out)
Is there any other info you need to see to pin this down?

Your technical support sorted this out: the problem is caused by the Realtime Antialising setting in the OpenGL tab. If it is checked, then the problem occurs as reported. I think this is a bug that should be fixed.

As I’ve mentioned elsewhere in the forum you should not use the Real-time anti-aliasing. It slows down everything and you can get a better result with the Full-scene anti-aliasing.

The Camera View shows all the layers by intention, and there’s no way to just turn off the layers just for onion skinning.

If you just want to see only the current layer, then you can go to the Drawing View.

If you need to see multiple layers, then you can go to the Camera View, but in your Network open up the Layer Properties of your Drawing layer, and then in the Drawing tab, you can uncheck “Read Underlay”. This will hide the underlay layer in the Camera View.


Hmm I just tried this on my computer, and was unable to reproduce this behaviour. When I’m in the drawing view, I see only the onion skin of the current selected sublayer. Unless I have the Preview button turned on, where it will show all the layers.

Personally I usually use two separate drawing layers for rough and clean, then you can just turn on the light table in the drawing view to see the roughs. Makes it much easier to delete the roughs later when you’re done with them.


I can’t see your images, but I took some screenshots of my own.

I have the first screenshot here that shows with the preview button off. I represent L for lineart and U for underlay.


Then the second screenshot here is with the preview button on, so that I can see both underlay and lineart. You can see that if I click and hold on the preview button, I can choose to show the underlay layer when the preview button is on.