OGL Transparency

Optimized OpenGL support with better video card performance, refined anti-aliasing capability and real-time preview of effects (transparency, colour scale and colour override)

Does this mean I should be able to get realtime transparency in OGL mode?
I only seem to get transparency when I render. Is there a pref to make this happen in OGL mode?
thanks,
jeff

Do you have Animate 2? Animate Pro 2? This should indeed work - I just did a test here, and when I add a transparency node I do see it in the OpenGL view.

If you don’t see it, can I ask what video card you have? What is your operating system? Do you have the latest drivers installed for your video card?

~Lilly
Toon Boom Support

I have an iMac running OSX 10.6.3.
The card is a NVIDIA GeForce 9400
not sure how to check driver version

using the PLE version of Animate Pro 2

I did an animation on transparency from 0 to full. I see it in render mode
but not OGL.

I just verified on my end with a fresh scene and I was able to add a transparency node and it worked just fine in OpenGL and render mode.

Just to double-check, can you attach a screenshot of your network view? Simply upload your screenshot to a free website like Photobucket and post the link here. I wanted to make sure that you have the network connected correctly. It should be drawing > transparency node > composite > display. However if your network were connected incorrectly, then it wouldn’t work in render mode either, so I am guessing that your network is correct.

At this point it’s probably best to have you send an email to support@toonboom.com. They can pursue the matter further.

~Lilly
Toon Boom Support

I use GPU ATI HD4830
but Why doesn’t show Real-Time Transparency on OpenGL Mode. I must Preview on Render Mode.

Thanks

Try turning off Real-Time Antialiasing. Go to your Preferences > OpenGL tab, and make sure that the “Enable” box for Real-Time Antialiasing is unchecked. Graphics cards will have a problem trying to calculate the transparency and the antialiasing at the same time.

Let me know if that works.

~Lilly
Toon Boom Support

yep, that worked for me. So how do I get both antialiasing and transparency?
a better graphics card?
thanks,
jeff


Well at the moment Real-Time antialiasing and real-time transparency aren’t supported to work together. What you can do, however, is you can try using the new “Full-Scene antialiasing” instead of our software antialiasing. What the full-scene antialiasing does is it uses the antialiasing on the graphics card. Go to Preferences > OpenGL tab, turn off “enable” on real-time antialiasing, then turn it on for full-scene antialiasing. If you’re on a Mac, put the samples up to 4.

Now quit the application and restart. Do you see both antialiasing and transparency now?

~Lilly
Toon Boom Support

as a matter of fact… it does.
thanks for the tip!
Jeff