New brush - Autosave?


just starting to get my feet wet with Animate, and I have a couple of questions:

1. I created several new brushes, set the properties and used them fine. When I saved and closed the file yesterday then re-opened it today the brushes have disappeared from the list. Did they not auto-save? Should I have done some ‘save’ process to make these brushes available for later use. I can’t believe that I should have to re-create the brushes new, for every session, so I’ve obviously missed something.

2. (A very minor item)When I start Anmate and see the Welcome Screen, it always defaults to NTSC, is it possible to change the default setting as I can never see me using NTSC.

Bernard D

I tried it here and it saves the brushes. I tried on XP and Mac OsX and both conserve the new brush I did. I renamed it newone with some new settings and it works.

On what operating system are you? Are you saving remotely on another machine? Are you with the PLE or the real version? Did you log in as the same user?


thanks for the reply.

I’m on the full version, using Win XP with SR3. This is my own machine and I’m an logged in as administrator, so permissions shouldn’t (and never has been) be an issue.

Weird. If nobody can offer a solution I suppose I’ll have to report it as a bug. It’s still doing it.


Bernard D

On XP the preference file that stores the penstyle is here

C:\Documents and Settings\your_user_account_name\Application Data\Toon Boom Animation\Toon Boom Animate\full-760-pref

You are not on a domain or a remote user right? Just for a test try to force the permissions on those folders.

Do you have the PLE and full installed? You could make sure the PLE is removed it that is the case.

Did you do Save of the scene? It shouldn’t matter since it’s not saved in the scene’s data but just in case.

2- You have a file you can change to set the default:

C:\Program Files\Toon Boom Animation\Animate\etc\resolution.conf

default HDTV
resolution HDTV 1920 1080 fps 24 H
resolution film-1.33 2048 1536 fps 24 H
resolution film-1.66 2048 1234 fps 24
resolution NTSC 720 540 fps 24 V
resolution PAL 768 576 fps 25 V
resolution low 360 270 fps 24 41.112

Just change the default to the name of the other resolution you want to have as default. Like here I put HDTV.

Thanks again for the advice, unfortunately number 1. didn’t work.

I already have full permissions on that folder, but just to be sure I added ‘Everyone’ and gave that user full permissions also, but that made no difference. There are three files in there, ‘Animate-pref.xml’, ‘Shortcuts.xml’ and ‘vectorizationPresets.xml’. Is that what should be there?

Your second piece of advice, on changing the startup default works fine.


I achieved what looks like a solution. I installed Animate on my laptop, swapped the licence to that, saved the new brushes, then copied the ‘Animate-prefs’ file from the laptop to the desktop machine. Swapped the licence back again and now I can create further new brushes on the desk top machine and they seem to be saved.

Strange, because the file opened OK in notepad and didn’t look to be corrupt in any way.

In any event; many, many thanks for your help.

Regards and have a Merry Christmas,

Bernard D