need help getting keyframes to work

Okay. I completed my cutout puppet using the pipeline from the rigging tutorial videos and I am struggling with getting it to animate.

I put it the puppet in the library and did the keyframe on the cells in the first frame.

I created a new scene and dragged the template in. I made sure that the animate button and transform button were on.

Since the video tutorials haven’t gotten to animating yet, I used the Animate Getting Started Guide. That said to click on the frame for the next pose and press F6. Using just F6 gave me a keyframe but the puppet would only display on the first frame.

That’s the problem. In frame 1, the first frame of the animation, I can see the puppet. I can transform the puppet. When I add the next keyframe, I don’t see the puppet in the new keyframe.

Here’s a picture of the timeline after I add the keyframe.

http://lily.maloquacious.com/ticket00008.png

There’s an arrow between the keyframes. The guide shows only a solid line. I don’t know what the difference is.

I’m using the Adobe shortcuts since that’s what was recommended in the rigging video tutorials. For Adobe, F6 is “Insert Keyframe and Duplicate Drawing.” I thought that I should be using Command+F6 “Insert Keyframe” instead of F6. Please let me know if that is right.

Using that key, I got the same results. I then tried a whole bunch of things, got a little bit frustrated (which is becoming the norm with this program) and I don’t know how but I got the following:

http://lily.maloquacious.com/ticket00006.png

See that empty square in frame 4? I don’t know how I got it. But now I can animate between frames 1 and 4. You can also see that the puppet displays in frame 4, complete with onion skinning.

But I still can’t add another keyframe. Trying that gives me:

http://lily.maloquacious.com/ticket00007.png

Which puts the line with the arrow between the keyframes. You can see that there’s no puppet in the camera view.

If I drag that empty square to another frame, it becomes a solid square and a line appears from frame 1 to it. I can still animate the puppet.

But, i’m back to where adding an additional keyframe doesn’t allow me to animate.

Other bizzareness is that sometimes I can double-click in an empty frame and press Command+F6 and get a keyframe that is not connected to anything.

I’m sure that as usual there’s some step that I’m overlooking. I don’t know what it is from reading the tutorials and watching the videos. I’d appreciate it if someone could point out my mistake.

Thanks.

The way you did it first is correct you just need to extend the exposure of the other frames. go to the last frame of your animation, select that frame for all the layers you want to see and press F5 to extend exposure.

Thank You!

That worked. I don’t understand why, though. Extending the exposure wasn’t mentioned in the tutorials. But your tip gets me back on the road of progress.

Wow. I’m pretty happy to have gotten this far with it.

http://www.youtube.com/watch?v=5Jd7ltBkH3E

Thanks again for the help!

glad you got it working! Your snowman looks like it is moving well.

The reason you have to extend exposure is by default Animate leaves the next frame free for you to do your next drawing. However if you just have 1 drawing that you want to animate you want it on all the frames which is why you want to extend the exposure of that drawing for all the frames.

Also note if have a drawing on say frame 1 and you draw another on frame 50 then it will automatically extend the exposure of the drawing on frame 1 to frame 49.