My animations don't play in GL view or Render view

I’m just trying to animate a couple seconds of a ball bouncing. Very simple, only two layers (background and ball). When I hit play in GL view, it MIGHT play once through one time at actual speed, but when it loops back (I have it set to loop) it plays it at maybe two frames per second. If I play it in render view, even though it says it’s 100% rendered, it won’t play at all. It is just so darn laggy. Other than the playback, the program doesn’t lag and works just fine. I have QuickTime and I’ve tried uninstalling and reinstalling the program.

I have a very basic laptop (hp elitebook) with stock everything (4 gigs of ram, standard hp graphics card) what is the best thing I can do to boost the processing power and get this program to actually work? I have no problems using flash with my computer as it is. I like the drawing tools better in toon boom so I’d like to keep using it after my trial is over.

I run essentials if that matters…

What year is the laptop?

Unfortunately your laptop may not be powerful enough to run Harmony adequately.

The graphics card is limited. That is where Preview processing is handled. It may help a little by disabling anti-aliasing in Preferences. You probably need more help than this will accomplish.

The next problem is that you only have 4MB RAM. The minimum recommended is 16MB for Windows.

These two elements are important for the creation stage.

The CPU handles rendering to animation files. Render View is different than rendering to a file. Render View is just a simulation created by the graphics processor.

Generally, the most noticeable upgrade you can do is to replace a main drive with a solid state drive. The speed increase is visible. However the “lagging” you are experiencing might lessen but you will still have a bottleneck at the graphics card.

My laptop is a 2015 I believe. This is what I thought. I guess I’ll see if the SSD helps improve the speed, othwrwise I’ll just have to run flash until I can afford a better computer
Thank you for your response!