Music Files Won't Work

Please if anyone can help me, I am newish to Harmony and have before imported music files, though I have done these at school on a desktop. Now on my personal laptop, I have tried importing three different songs, two of which I was able to do at school. I have each file in mp3 format, though do I need to put these files through an audio converter? I have tried going through preferences, I have made sure the audio symbols are clicked but to no avail. When I render there is an error that the audio cannot be read and one more thing the wavelengths do not show. I am in desperate need of help, thanks if you try to help me with my dilemma.

What steps have you used?

  1. Open your project
  2. Go to the top file menu File => Import => Sound
  3. Scroll / Navigate to your sound file. (Harmony will gray out any file type that is not supported).
  4. Once selected press the Open button.

Your project should now have a layer in your Timeline that is the sound layer. If there is any low volume or silence at the very beginning of the file the waveform will only appear as a straight line. Your project has to have a large enough scene length to get to the portion with audio on it.

You can double-click on the layer name in the Timeline to open up the Sound Element Editor which will allow you to play the sound file in its entirety regardless of the project’s scene length.

Importing: http://docs.toonboom.com/help/harmony-14/premium/sound/import-sound.html

Exporting: http://docs.toonboom.com/help/harmony-14/premium/sound/export-sound.html

Thanks for trying to help, I went through these steps and did it once again as you stated. The wavelengths are just not appearing for some reason. Right now I am trying to convert the file from mp3 to wav to see if that changes anything.

Update: Changing the file to a .wav did nothing.

Are you on Windows and, if so, do you have Quicktime installed? Advice was issued a while back to remove Quicktime on Windows due to security issues, however the codecs are required by Harmony. The second comment on this post describes how to do a ‘custom’ installation to only install the codecs and not the Quicktime Player. This solution worked for me when I was unable to see waveforms/work with audio.

Are saying that there is not even a straight line without any waves showing up in the keyframe section of the Timeline after creating the sound layer?

If there is at least a straight line it means that the sound file is quiet in the beginning and there is not enough sound to produce a visible wave until later. If your scene does not have enough frames the section with the waves is not going to fit. If you click on the name of the sound layer you will open the Sound Element Editor. There you can use its Play button and the complete sound file can be seen and heard regardless of the limited size of your scene.

There is a line, just not any varying wavelengths. The song does not have any silence in the beginning, so it should not be flat. When I enter the Sound Element Editor and press the Play button no sound will play for as long as I play it.

Yes, I do have Windows, so I have to have QuickTime installed? (I ask this because of the security issues). I just tried this, is it just having the codecs on my laptop supposed to let the audio work? I’m going to uninstall and the reinstall the way said again the post you linked to, I’ll put and update here if it works or not.

If it’s Windows 10, Quicktime’s most recent versions will not work.
You need to install 7.7.6 or earlier version.

https://support.apple.com/downloads/Quicktime%207.7.6

Also check the “Play” menu to make sure “Enable Sound” is checked.

Due to the system error of the music decompression software, I was too late when the topic was closed for so long.
Regarding the music theme, you need to install free phone ringtones, please refer to the klingeltöne kostenlos website which offers the most popular free ringtones today with an unlimited number of ringtones.