Moving elements

I’m new to this, and working through the two legged animation workout.

My problem is, I cant get the Shift/arrow key to move any of my elements.

I have the “transform” tool selected, so that’s not the problem, any ideas anyone of where I could be going wrong?

I’m using version 4 of the software.

Well, select the Camera-View / select either the Select-Tool (6) (no keyframes)
or if you would like to set keyframes, choose the Transform-Tool (7).

Select your object in the Viewport (click on it) /
(always tick on your object in the viewport to make it active,
otherwise the arrow-keys wont work).

Now hit the arrow keys - you will see your object slightly moving /
hold down the shift-key and your increments getting bigger.


Thanks for replying Nolan, I followed exactly what you had written, after 4 attemps I got my object to move, but further tries later on got me nothing again…could there be a slight glitch in the programme? it’s not that it’s a complicated move that I could be missing a step on.

Well, I am really not sure if there could be a “slight glitch in the program” -
but one never knows… (what are your program- and system-specifications ?).

Be aware if you select a colour, or work in the timeline, the viewport becomes inactive,
please make sure that you always have to give your object in the viewport a mousetick again, to make that view active again.


Hi Nolan

I’m using windows XP on a Toshiba aptop, 1gb Ram.

I tried again to move the object, which in this case is a donkey, I selected the trannsform tool, I highlighted the peg for the donkey, I then clicked on the camera icon in the window, then hit the arrow keys…nothing…

Then I tried clicking the view window, and repeating the process, still no joy .

Is there any other way to achieve this, apart from the funtion editor?



Well, I am running out of ideas…

Check Tools / Turn Peg only Mode - switch it off.

Please try alt+down-arrow / up-arrow to move the element forth and back.

In the Properties type different values in the Offset windows and hit return.

Are any of your objects showing any movements ?

I presume you still can move your objects manually in the viewport ?


No. It is just a matter of gaining “focus” in the camera view pane. Try the following:

When you select the peg for your object with the scene operations transform tool active do you see the desired object bounded by the transform bounding box with the unfilled square corner grab handles? If not the object is not selected.

Now look up at the top of the window at the top tool bar and find the three icons for doing field guide or grid related work. (they resemble a cross hatched grid shape) If these icons are “grayed” out then the camera view panel does not have focus and the shift arrow key functionality is not enabled to move your object.

To get focus in this camera view pane you need to mouse over the center of the transform bounding box and click your mouse button. ( I usually look for the “four way” arrow to show before I click the mouse button) As soon as you do, you will see the grid icons turn “dark” indicating that the camera view pane now has focus and your shift arrow keys are now enabled to move the object. The grid icons are a quick visual indicator of the camera view pane’s current focus status.

There are several types of functionality that require that this camera view pane has focus, things like moving objects or copy and pasting of drawing objects etc. so you can always watch the grid icons on the top tool bar to know if you need to click inside the camera view pane to give it focus.

One additional tip: To easily distinguish between camera view and drawing view it is useful to set the drawing view background color to something other than the default “white”. This is done in “preferences” on the “Interface” tab. I use a cream color off white but it is a personal preference. -JK

Aaaahhhhh brilliant !! Now I’ve got it !! thank you both for takingthe time to answer my question. I could see the bounding box, but the grid was greyed out, afer I clicked into one of the white squares in the bounding box, I gained “focus” and was able to have that donkey runin’ all over the screen.