Moving a selection of frames/key frames creates new key frames at beginning.

So while animating I sometimes have to move around large groups of frames to adjust timing. When I go to move something, I’ve noticed it starts adding keyframes in my timeline that I do not want.

Example: I have 3 pegs. I want to move animation on all 3 pegs further down the timeline. The peg in the middle only takes up 3 frames at the end, but the top and bottom pegs have 6 key frames. When I select them and move them, I notice that the middle peg now has a key frame at the beginning of the selection.

Is there a way to have it not do this? I’ve searched the forum and I’ve dug through the preferences but I can’t seem to find any info on this. Any help is appreciated.