Movie export all kinds of messed up

I am trying to export a video in a suitable and reasonably sized file for Vimeo and Youtube HD. The video size is 1280x720.

When I export using the animation codec, everything is fine but the filesize is huge.

When I export using MPEG-4, all the colours get a lot brighter;

http://www.lpbaker.com/files/colourdiff.jpg

If I try exporting using H.264, it does two frames and then throws an exception;

http://www.lpbaker.com/files/exception.png

I’m using Animate 2 7.9.0 (5660) under OSX 10.6.4.

Help!?

Thanks,
Lindsay

In the Standard Video Compression Settings “Compression Type H.264”…
Check the Radio-Button “All” for Key Frames…

Then try these settings:

Compression H.264
Frame Rate 25 or 30 / or Current
Quality High / Multi-pass
Data-rate Automatic or at least 3000 kbits/sec
Size / Resolution 1280 x 720 / Deinterlace
Sound AAC (or IMA 4:1), Stereo, 44.100 kHz, 128 kbps

Upload that movie to Youtube:
The initial display of your video will be still in normal quality,
but now you have the option to click on the “watch in HD” button…

Example:
http://www.youtube.com/watch?v=CXSwJe47u74

Regards
Nolan

That scene reminds me of the holy grail.

The colours do change depending on which codec you use. The reason for this is that sometimes the way that the codecs compress the information in the file is by compressing the colours - and different codecs do this in different ways. For example you may find that when you do an H.264 compression your colours might appear a little desaturated and lighter. This is a part of the compression process.

~Lilly
Toon Boom Support


It is from the Holy Grail - the animation will be online soon :slight_smile:


Thanks, but no matter what settings I use, Animate gives me that error.


They should not change that much. If I export the animation from Animate using the Animation codec, load it into Quicktime and use Quicktime to export the animation into Mpeg-4 format, the colours come out identical.

That, plus the H-264 error, leads me to think there’s definitely something not right about the encoding engine in Animate, but I have no idea what to do about it.


The encoding comes directly from Quicktime. We use Quicktime to do the encoding, there is no encoding engine in Animate. This is why you would not be able to export to Quicktime without already having Quicktime installed on your computer.

That St9Exception is what I get when I do Keyframe “Automatic” instead of Keyframe “All”. Make sure that you have adjusted this setting in your export settings. When you export your movie, click on “Movie Options”, then “Video Settings”, then under “Motion” you want “Key Frames: All” radio button.

If this does not solve your problem, then there’s nothing more I can do to help you without connecting to your machine so you’ll need to email support directly at support@toonboom.com.

~Lilly
Toon Boom Support

H.264 is now working, you were right about the keyframe setting, thanks :slight_smile: