Morphing Layer Problem?

i have face a weird problem on morphing layer process
i used to do it with digital pro and i have done before but in animate pro 2 i found it has a bug on it .

when i tried to draw on the drawing cell of the “from” field it draws on the first drawing cell of the morphing.
as well as when tried to draw on “to” field it draws on the finished drawing cell of the morphing.

please could you find the following pics :

Sorry i didn’t mentioned that the technique worked on drawing view But not Working on Camera View??

I had to double-check on this one before I could answer it, but the answer is that it was designed to be used only in the Drawing View, and not the camera view. There are some features of Morphing, like the thumbnail of the other key image, for example, that work only in the Drawing View. So this is not in fact a bug, but rather by design.

When working with morphing, it’s good practice to have both the camera view and the drawing view open at the same time, since the drawing view will only show the drawing that you have selected, whereas the camera view will show the current frame. This allows you to make adjustments on the drawings or on the hints and see in real-time how these changes affect the morph.