Modules not automatically connecting in Network

First off, yay for a Harmony forum! Now, to business. I’ve been playing with Harmony 9 for the last few weeks and have noticed that my drawing modules are not automatically connecting to the composite when I add them in my timeline. The weird thing is that I can see them and have even animated them in camera view (weird because they are not connected to the display module), I only notice it when I go to render my project and it comes up empty. This never happened in the old Harmony (or Animate Pro for that matter), I couldn’t find a setting to check in preferences - am I missing something?

PS I’m loving using 9, particularly the new line options and deformer - huge step up!

I am having the same issue.

Just recreated it with a new project. When set in “display all” a new drawing layer is not automatically connected to the composite. When it is set to “display” it does auto connect.

Ah, interesting. Yeah, I don’t think it is automatically set to display all but I remember being told (by the ghost in the machine) at one point that I needed to turn on display all to do something (can’t remember exactly what). I’ll keep an eye on it and report back when it comes up again. Thanks for the help guys!

Yes, when you try adding a peg it says to switch to" display all".

Yeah, it happens when I add the peg in the timeline and when you do that it basically just lays the peg in the network on top of stuff so you can’t really tell that it just disconnected your drawing layer from the composite. I tried adding a peg in the timeline view and there was no issue. Funny thing was that it only told me I needed to be in Display all when I added the first peg, then I went back to regular display and it never gave me trouble adding pegs after that (and didn’t disconnect the drawing modules then).

I have been adding them in the timeline only when this happens.

I meant to say that “I tried adding a peg in the network view and there was no issue.” It’s only adding in the timeline when it tells me to display all and then proceeds to disconnect everything that I add a peg to.

Thanks Lilly

Let me see if I can investigate this one a little bit for you.

For the display thing, check to see which display module is showing in your Camera View. To do this turn on your Display toolbar. If it’s set to Display All, then it will attempt to show all the modules regardless of whether they’re connected to the composite.

For the modules not being connected, when you’re adding them, do you have anything selected? I’ll try to reproduce this one here on my end.

I just created a new scene, and I tried to add some drawings, and they’re all properly connected. I tried creating them when some drawings were selected, or when none were, and in both cases they still connected.

I then tried creating a group, and going inside the group in my network view, then creating a drawing from the timeline. It created a drawing outside the group, connected to the main composite.

No matter what I tried to do, it always created a drawing back on the main composite.

Was the scene originally created in another software? Perhaps there’s something with the conversion. We might need to test with your files.


Aha okay. Well, I recommend not leaving it to Display All ever - it shouldn’t be set to this by default - because you may get mistakes happening by having unconnected modules appearing.

The Display All was originally created to work with Animate, which doesn’t have the use of the Network.


How are you trying to add the peg? Are you adding it in the Timeline, or in the Network View? Are you adding it by clicking on the + button in the Timeline or by clicking on the Add Peg button directly? Do you have a layer selected when you try to add the peg?

I suspect it might be asking you to change to Display All because the Timeline displays according to a display module. If you create a peg, and it’s not connected, then it’ll probably ask you to switch to display all, otherwise you won’t be able to find your peg unless you’re in the network view.

I suppose most of the time I work with the network view open, which may be why I’ve never seen this message before. I’d like to have more info on exactly how you’re adding the peg when you get the message. Do you have the Network View open as well, or only the Timeline?



I’m investigating this issue with the team now. I can reproduce it here, and I understand why it’s giving an error. It’s when you try to add a peg that’s not connected to anything, it can’t display in the Timeline a peg that’s not connected. If you try to create a peg while you have another drawing layer selected, then it works, and it becomes a parent of that peg.

If you want to add an unconnected peg, then the Network is the best place to do that. I’ll see if there’s anything else that we can do here but I think the error is given in good faith.