MacOSX Mavericks - Freezes on bone animation

I am facing problems with ToonBoom Studio. I don’t manage to put bones in my characters. When I get to the point of putting the envelope the ToonBoom Studio 8.1 freezes. I need help.

My configuration is:

  • MacOS: Mavericks
  • RAM: 4Gb
  • Version: ToonBoom Studio 8.1


Paty Martins
(One desesperate amauter user. Lol…)

Another amateur user here. How old is your Mac? I have Maverix on a 2010 iMac (2.97ghz i7 4gb) and I have no problem using bones. It’s sluggish, but I think it’s more the fault of the app than the Mac running it.

My macBook (2010):

  • Intel Core 2 Duo 2,4 GHz
  • 4Gb RAM
  • NVIDIA GeForce 320M with 256MB of SDRAM DDR3

Try making it the first app you use after starting up? Get more memory? More VRAM? Have you opened and altered any PREEXISTING sample designs with bones and had the same bad luck? (I’m basically throwing stuff against the wall here.)

My problem is that when I use the bone skeleton, the toonboom template (preexisting) or not, the program simply blocks. I don’t know what I should do. I believe that the problem is with the app. I tried in another computer but the program blocks in the same part.

What are the specs of the OTHER computer? In my short experience with tbs8.1 I find that the thing is sluggish as hell, which surprises me; you’d think that the makers might have tried a little harder to ape Flash more successfully. (Also: osx updated again a few days ago. Try installing that?)

This Skin you’re using isn’t complicated, is it? The one you’re trying to Bone. Again, grasping at straws here.

After many attempts I managed to do it! But only after removing all the paint from my character. Then I just paint it after putting the bones. I still think this is not quite right but at least I can finish my animation.
Thanks for your help.

Must’ve been some paint. Well done.

You might also check your preferences. Maybe something in the rendering options can be changed to make it more workable.

There is little point in using bones if there are no textures or bitmaps in the character rig. You may be better off using a peg structure instead. Also, your graphic card may be the cause - it is an entry-level card for laptops (M cards are laptop cards). You would have better results with a more capable card.

Thank you for your suggestion. I’ll try later etui samsung galaxy tab 3 10.1