Mac format issues and V2

Some background, on a Macintosh, if I save an Animate file with just the name, a folder with that name is created and can be opened like any other folder. Inside that folder is the .digital file and the other folders for images and Palettes.

And if I want to import the color palette from that Animate file into another, no problems.

However, when saving a new Animate file and I append the .digital extension, what’s create is a Mac OS X “package” file. I can right click on it and select the contextual menu item “Show Package Contents” and all the usual files and folders from the previous method show up.

The issue is that from inside Animate, I can only import palettes and such from a Animate file that was orginally saved without an extension. If a file was saved with an Animate extension (.digital) the import palette dialog box doesn’t “go inside” the .digital package.

From earlier posts, iirc, I was told to just save the file without the .digital extension.

And that’s where I’m encountering some weird issues. In the extension-less files, the Z-position (and the X and Y position as well) gets mucked up. After changing the Z position (by micro-nudge or by typing in a value in the Layer properties palette), saving the file and then quitting Animate. When I re-start Animate and open the file, the X,Y and Z position entry boxes in the Layer Properties palette has text with the layer’s name, followed by a colon and the numeric value of the position.

The only way I’ve found to be able to “re-set” those values is to save the file as a .digital file (which makes a Mac OS “Package” file) and then the X,Y and Z values can be changed.

And to be able to import a Palette from a Package file, I right-click on the file, select Show package contents and from the new window, just option-drag the color Palette folder to my ‘work’ folder. Then I close the package window and the palettes can now be imported.

Now, I make sure that all Animate files I create has the .digital extension and just follow the previous paragraph’s steps to share/import a color palette.

With that all out of the way, will Animate 2 be able to “see inside” of Mac’s Package files (the ones that have the .digital extension), so palettes and such can be imported with out the opening package steps?

Hope this was somewhat clear, I’ll be glad to elaborate if it wasn’t.

Thanks for any feedback!

Hi Mike,

What OS are you on? 10.5.8 or 10.6?

I’m working on 10.5.8 here, and when my Animate files are saved they create a folder with the .digital files and then there are other sub-folders, one of which is called palette-library, and inside of that folder is my .plt file. From another Animate scene, I can go to the colour window and from the little menu at the top-left of the colour menu I can go to Palettes > Import. I can then just browse to the .plt file from the Documents folder > Scene folder > palette-library > palette.plt

Are you not able to do this for some reason? How are you saving your scene file? How is it creating a package file?

The implementation of this has not been changed from Animate 2. You should be able to import any palette by going Palette > Import… then browsing to the palette file.

~Lilly
Toon Boom Support

Start up Animate.

In save file, save the file as "test01.digital"

Create a new file, which will automatically close "test01.digital."

In the color palette, click on the Import palette button.

If you navigate to where “test01.digital” is, notice that it’s (at least on my Mac running OS 10.6 – and it was the same on 10.5.x) icon is that of an Animate file and you can’t import anything from it.

The trick is to save the file with a .digital extension to get this behavior.

Guess what I really want to know is that should I save the Animate file manually with a “.digital” extension, or just save the file sans extension and let Animate do what it wants.

In either case, the contents of the Folder and Package are the same. Animate just can’t import anything that’s within a .digital Package file, but can if the project just is within folders (saved w/o an extension).

The X,Y and Z postion issue could be related to saving a .digital file with out the extension during a “save as” operation.



I’m on an Intel Mac, 6Gb of RAM and Mac OS X 10.6.2.

Thanks for the response.

Hi Mike,

Okay I was able to reproduce your problem. Basically when you create a new scene, you give it a project name (no extension) and then when you hit “save” it saves it correctly. It’s if you try to do a “save as” that it seems to want to create the .digital extension. If you manually take away the .digital from the “save as” window, then you get the correct folder structure and it’s not put into a package.

I don’t believe that doing a “save as” and taking away the extension should produce a problem with the x, y, z position. In order to investigate this, I would have to run further tests, and perhaps it would be useful to have your scene file.

In any case, as regards Animate 2, I can tell you that when you do a “save as” in Animate 2, by default there is no file extension added to your file. In fact, if you try to add a file extension to this, you may encounter problems - so you should not add an extension. There will be changes to file extensions, and if you manually change the file extension you will prevent Animate from being able to open the file.

~Lilly
Toon Boom Support

Thanks so much for the speedy responses! Makes me feel very good about ToonBoom and pre-ordering Animate v2.

So, short version, don’t bother manually adding in an extension. Just give a name to the project and let animate take care of the rest.

As to the XYZ position issue, I think it was because I was going from using no extension and then saving as and adding the extension and so on. In the to-and-fro-ing the issue happened. Unfortunately, I do not have any files that exhibit this issue as I had to fix it all and didn’t save the “bad” versions. If I have some time over the next couple of days, I’ll try to reproduce the problem and come up with steps that can replicate it.

Thanks again!

Always glad to be of help. :slight_smile:

~Lilly
Toon Boom Support

Figured out the X,Y and Z position issue…

It happens when I import a symbol and then I can go to the layer properties palette and in the settings for the layer, click on the graph button and a pop-up menu appears and I just choose “Local” and I can type in the actual values. However if I leave it alone (and the text entry box has the symbol/layer’s name and position value) and go into Animate mode, I can micro-nudge in Z (alt/option- up/down cursor key), so it’s all good.

I’ve made a character template containing a full turn-around in 7 frames and have placed it into my scene and starting to block in my animation (big moves first, then refine and refine…). Not having any major (or minor) issues. Yea!

Excellent! Glad to hear it! Thank you for clarifying your issue. Yes when you set the properties to “Local”, it sets it back to a constant value again, so that would work as a way to reset.

~Lilly
Toon Boom Support

S’more info:

When dropping a cut-out character template onto the timeline or Camera window, the Function Curve, in Layer Properties, for the Master Peg layer must be set to “Local” instead of the default (that has the name of the template, other info and isn’t editable), in order to be able to use the Transform tool when animating. Otherwise, the selection “square” (with the solid squares for the corners and middle of each line) won’t appear.

So, the Master Peg layer being set to Local, isn’t to reset the values, it’s to be able to animate the Master Peg with the transform tool.

Although the actual symbols will not be set to Local, it hasn’t affected animating … so far. I can see the logic in this, because the symbols relationship to each other is very important in a Cut-out and to micro-nudge a part forward or backwards, needs to be done within the symbol (as per the User’s Guide) so that the relationships between the parts are the same (except for the piece you moved) – and the Master Peg still maintains its position in the local scene.

Now, when using IK, I got bones all over the place. But that’s another issue that should get its own topic or email to support.

Some updates and stuff:

The IK bones issue cleared up when I discovered that there were duplicates of the cut-out character’s symbols in the project’s library. I deleted the character from the timeline and then deleted all the symbols from the library. Then I dropped the character template back on the timeline, and the bones were normal and usable again. This is one case where having a dialog box to warn/inform the user that there are dupes would be handy, instead of Animate just appending a “(2)” to the dupe’s name.

In the process of doing this, I tried to delete some exposures of the Character on the timeline, got a dialog box that said that the action wasn’t undoable and I clicked “ok” then closed Animate (a trick to undo the undoable, usually works) and when I tried to restart Animate, it wouldn’t load up. Something about not being able to find an “image” – I reinstalled Animate and all was okay.

About the missing selection “box” (the rectangle that surrounds an selection when using the transform tool in Animate mode – the box with the solid squares at the corners and in the middle of each line that makes up the rectangle), It only vanishes when the Master peg of the character is placed more than 11.98X forward in the Z axis. In the process of doing this, I learned that the “Local” setting in the Function curve, in Layer Properties, has no effect on animating or selecting. So when I drop a template on the timeline, I don’t have to change any thing in the layer properties of the Master Peg layer.

After all of this, doing a walk cycle will be a piece of cake. ;D

btw, will Animate v.2 be able to “understand” the side-to-side swipe on an Apple Magic Mouse when the timeline has the focus? This would make scrubbing so much easier!

When you delete drawings in Animate and it gives you a dialog telling you that it’s undoable, what it’s really indicating is that they will be immediately erased.

The Apple Magic mouse’s side swipe acts as a horizontal scroll, correct? At the moment, the timeline does not support horizontal scrolling, but I can certainly log this as a feature request for future versions of the software.

~Lilly
Toon Boom Support