Lost keyframes and image

I have created an animation of Titanic hitting the ice berg and the ice berg sinks.
Saved it last night opened it up this morning the ice bergs are there but no Titanic, the label is there in the timeline but no keyframes they have gone. There is a small square box with an arrow in it and the programme has renamed it Titanic-g.

I have checked the files in the folder and the name is there but nothing in it looks like its disapeared seems a bit spooky, any ideas anyone? B4 I start all over again.

Many thanks Mike

Hi mikeS

I like your concept, and I am sure the passengers would have liked it to happen that way too.

When it comes to your problems I have no idea what has happened.
Some things that you should sort out are:

Cheque that you are in camera view.
Cheque that the actual layer is turned on, a chequemark to the leftmost part of the layers name.
Cheque that the cell/cells are showing the right drawing, you can do that in the library drawing substitution window.
Cheque that you have not chosen a sublayer, In the drawing view there are some icons in the bottom left. If you press them you will work on sublayers. They are called underlay art color art line art and overlay art.
usually you work in line art. The far right button of these gives you the oportunity to chose wich layers will show.

When it comes to dissapeared key frames I have no clue.
The little box with the arrow might be a group element in the timeline.
If you have grouped your layers and closed the group in the timeline, the layers will not show. Just click the Little angle to the left of the group icon and it will open and show the layers in the group.

If your problem is non of these please tell and give some more info.
There may be that you by misfortune have not saved your scene. Animate/Animate Pro do not autosave, you have to save regularly and when closing the app.
Best regards

Are you storing your scene on your local disk or remote to another machine? If so try to save on your machine. It might have been a save issue.

The titanic-g sounds like a group. Did you try to expand that group by pressing the triangle to the left?

Can you make a screengrab? It would maybe be more obvious.

It happened to the same! and I have never find out how to fix it…If his problem it’s same as mine, the library drawing substitution window appears empty!
everything was saved regularly

Hello Ivor and Steve

Thanks ever so much for you replies.

Since my first post I re made the ship again and animated it. Hit the save to my hard drive a few times to make sure. Nervously closing the programme. Re opened Sure enough same thing happened again Only the drawing label in the timeline view. With no key frames and no ship. Also the groups are there but nothing in them. The icebergs are there and keyframes OK.

I have done all the checks as you suggested without success I have experimented with other animated drawings and these are all OK.

The one possibility I had thought off. Would there be a limit to how many items you can have and save in any one group, that is the number of components to make up the ship? In this case there are 30 items for the ship and only one for the iceburg. I even saved the ship in a different file name The file is there but still no ship.

I am going to re draw the ship again this time making it more basic with less components and see if that does it. I will post back and let you know the results.

By the way Its a great programme, very pleased with it, and looking forward to buying once I have mastered most of it.

Many more thanks again


Did you try to look in the Render to see if they are there? It might be a graphic card display issue in the OpenGL camera view.

In the Library do you see the thumbnails when you select one of the ships layers?

Did you manage to save other images in the same scene besides the ship?

Do you have a non-english operating system? Do you have spaces or special characters in the path where the scene is saved or in the names of the layers?

Re Lost Key frames and images.

I think I have found the problem.

I re drew the ship again (4th time) only this time without going into to much detail that is reducing the number of components in the grouping that makes up the complete ship. 13 items in all instead of 30. This time on reopening the programme, all is as I saved it previously.

I will now remember to watch this as to spend all day doing a design and loosing it all in a second is a disaster.

It would be great if Toon Boon Technical could verify this point.

Is there a limit to the number of items in any one group?

Cheers Mike

Based in the UK.

Hi again

I suddenly remeber having had a similar issue, but have forgot the details.
As I remeber it, a scene would not save additional work added to it.
Why I never found out. But in my case there was a warning when closing.
Saying something like(my memory is not good at this):
Cannot save because the project is opened by another application.

So: Please store your layers in the library and create a new scene before you continue.
Then bring the layers into your new scene and see if that solve the problem.
Maybe naming can be the problem,(as Steve suggest) being a norwegian with some extra characters in the alphabet I know ToonBoom software don’t accept them. That also apply to imported images and files.

Hope you are soon up finishing your scene.


The programme saved the files as normal with no warnings of being unable to save.

This is the full UK English version so no unusual characters in the file names.

I can now tidy up the animation and complete the project.

Hi Lilly

Thank you for confirming that.

I drew the ship completely using the software only, no image imports.

The one thing I have found out having watched the video tutorials over and over. It seems that rather than trying to draw the complete ship in one layer. I need to break it up into several layers. Like the rabbit in the videos. Separate head arms legs etc. With the ship same idea separate layers for the Smoke stacks decking masts hull etc. Would you agree?

Regards Mike

Thanks Lilly

When I first drew the ship to include detail like the name, windows, and portholes, etc this is when I ran into problems. I saved the file frequently after including additional components there were no reports of problems in saving.

Until re opening the programme the next day. The timeline and image disappeared, the only thing I can think of is to include less detail. for example less components in the whole drawing.

At least I know now not to get carried away with adding to much detail in one drawing.

Kind Regards Mike

There is no limit to the number of drawing layers in a group. I have seen some studios that have literally hundreds. Is your ship made up of vector drawings that are drawn directly in the software? Or are they imported bitmaps?


Well, it depends on what you want to do with it. Anything that you want to animate separately, with keyframed layer animation, needs to be on its own layer. If you’ll only ever be moving the ship as one whole object, it being on one layer would be okay. If you want to do some squash and stretch on the masts as the ship hits the iceberg, though, then you might want those elements on their own layers.