License Wizard will not acknowledge my license

Ever since yesterday night, Toon Boom will not allow me to open Harmony or Storyboard Pro. Even when I login using the license wizard, the licenses are right there and it will say I do not have licenses. When trying to open either, it brings me this message under more info:

Licensing Error (MacOSX)
Trusted Storage compromised; repair needed
Trusted Storage is invalid and needs to be repaired.
Feature: MacOSX
License path: /usr/local/flexlm/licenses/license.dat
FlexNet Licensing error: -157,424

Googling this information only brings me to several other software services that use FlexNet. I’ve tried reinstalling, I’ve tried using the repair toolkit, I’ve had one person from support erase my old expired licenses. None of these work.

My day job requires that I use this software so being locked out of it is infuriating.

edit: I have also tried a method to remove the FlexNET folder and then run master disable in the terminal but that also did not work.

So through sheer poking and prodding I fixed the problem.

In the License Wizard I clicked Manage Active Licenses and looked for the licenses I currently had. I highlighted them and hit the “repair” button on the right hand side. That did the trick.