Layers Out of Order

So, in my project, I have several layers that are out of order. For example, I want one of my character’s arms to appear above another character, so I have the first character element above the second character. The x, y, and z positions are all set to 0, and the element types are “normal”. Despite all this, the top layer is below the bottom layer. If anyone can tell me what’s going on, that’d be great. The only thing I can think of is to manually change all of the z-axis properties, which would be confusing.

I can’t get this to work. I don’t understand why it’s not working like it’s supposed to in the first place. There are other layers doing this to, with one of my topmost layers appearing under the characters before changing the z axis.

Would you like to send me the project file so I can see what is going on?

I don’t think this can be resolved any other way.

You could also open a support ticket. Maybe a tech can dial into your computer and look at things.

Here’s a project file with just the frames I’m referring to.

I should have asked or looked closely at the screen capture image for the software version you used to create this project. I have a purchased version of 7.1 and I downloaded and installed the Trial version of 8.0. There is not an option to save to a file format compatible with an earlier version like in some software. I do not have 8.1.

Another approach at this would be for you to do what I would have done if I were able to open the file.

I will need for you to create several screen captures:

  1. Show the entire Timeline hierarchy.
  2. Show each drawing layer when selected in the Timeline and have the Properties window open.
  3. Describe and show the items that are wrong.

When you say this:

Changing the Z axis of one drawing should only bring that out front or push it behind everything. This should have no other effect except for relative size (the farther back the smaller it will look and the closer it gets the larger it will look when compared to everything at 0 on the Z axis. Getting it out front will not require so much that scale would be a concern.).

It is not readily clear to me which part is wrong. Please describe what you are trying to do with the characters and what part is incorrect. I see Capture4.png has the Z axis adjusted to bring the arm forward. Unfortunately, the drawing layer is not shown in the Timeline. It might not illustrate anything but I would still like to see it.

(For some reason experimenting in the Studio 8 Trial, if I adjust the Properties figures for X, Y or Z they do not have any effect on the drawing layer. If I manipulate the drawing layer directly where I can see the changes, the figures in the Properties window do not change. Yet doing the same thing in Studio 7 produces the results I expect to see.)

All I want is both hands over the character. This is a small thing, but I’ve noticed this problem occurring in other places too that have a greater affect on the video, such as when the characters are being crushed by an object. The object, despite being on top, appeared behind the characters before I adjusted the z-axis.

A few questions:

I am wondering how can the foreground be higher up the hierarchy than the characters and not cover them?

Which item is 3ds?

Earlier you said adjusting the Z axis messed other things up. What exactly gets messed up?

Isn’t the Corncob character occupying the virtual space between the Alex character’s arms and the space in front of that character? It would seem like the Alex right arm ought to go behind the Corncob body.

I attached another screen capture showing another instance of the problem. Everything seen is at a z axis of 0.

The details are so small it is hard to see. Is it the arms or hands of the Alex character again?

Can you do a closeup of the problem area?

On capture 13, I want the whale IN FRONT of the other characters. I was only able to fix this by changing a bunch of z axis settings.
Zip file of screen captures.

This is done using the Z axis, however you only need to adjust the element that overlaps something in the scene rather than believing that everything needs adjustment.

If I do that that will affect other parts of the scene. Shouldn’t the top layer automatically overlap the bottom layer?

By default everything exists at the same position on the Z axis regardless of where it sits in the Timeline Drawing Layer hierarchy. This Drawing Layer hierarchy is one way to have things dominate other things. That is until you need more options to pull off an illusion like one part of an object going behind part of itself or something else. Adjusting the Z axis is probably the most basic and easiest to begin with. Other techniques can involve masks or swapping parts.

The adjustment is so slight because everything is actually paper thin on the Z plane so it will hardly effect the perception of its size. It is just enough to allow something higher up the layer stack to slip underneath it.

Here is a video describing the spacial aspect of the Z axis in Toon Boom. The software is Animate Pro but the principle is the same regardless. Hopefully the different software will not confuse things: (about 3:40 begins the part that touches on this concept. He builds the hierarchy at 6:25 then goes on to working out the overlap with the Z axis).

If both layers are at a z position of 0, shouldn’t the top layer automatically appear over the bottom layer. Because this isn’t happening, and changing the z axis position just messes everything up.

I am getting a little confused with what you actually have set up so here is a hypothetical situation. As shown whatever is above would appear in front of everything underneath it.

(NOTE: If you have a Drawing Layer selected, it comes forward in the display window only and appears to rest in front or on top of other layers in the scene/drawing/camera/window but that is only temporary while you have it selected. Also of course if you make anything invisible it is temporarily not a part of the equation.)

Timeline Hierarchy

Character 1 Head
…1 Neck
…1 Upper Torso
…1 Hips
…1 Leg F Upper Leg
…1 Leg F Lower Leg
…1 Leg F Foot
…1 Leg B Upper Leg
…1 Leg B Lower Leg
…1 Leg B Foot
Character 2 Head
…2 Neck
…2 Upper Torso
…2 Hips
…2 Leg F Upper Leg
…2 Leg F Lower Leg
…2 Leg F Foot
…2 Leg B Upper Leg
…2 Leg B Lower Leg
…2 Leg B Foot

They all rest at 0 in Z axis. If you want “2 Leg B Foot” to overlap “Character 1 Head” you nudge only “2 Leg B Foot” forward using the Z axis. Of course you may need to nudge other portions of the leg if they overlap anything in order to get a plausible result. However, nudging one piece should not effect anything else in the project file.

If you are seeing a different result can you create screen captures and upload them somewhere that I can view them?

Attached a screen capture to this thread. Yes, it’s a Pokémon parody. All of the layers with drawings are at a z postion of 0 except for alex_arms, which are at .01 so that they’ll appear in front of the main body. I want both arms above Lucario (character 2/Corncob).

Have you tried bringing both arms closer to the camera making one of the two arms a little closer than the other with everything else at 0 on the Z axis? With the character’s bodies woven together you may have to think of them as 3D objects just like in the real world of full volumetric form and move several parts on the Z axis to allow for overlapping parts.

Finally seemed to fix it. The layers WERE at different z positions, but they were so close to each other that the program showed 0.