Lasso Tool Selecting Multiple Lines Instead of Just One


I’ve been using Toon Boom Harmony Advanced without any issues for about a year now. Something I really like about it is that when I lay down a drawing with the pencil or brush tool, if I don’t like a certain line, I can just select that one line and delete it, without any of the other surrounding/touching lines being affected.

But today when I sat down to continue working on my animation, suddenly when I went to select just one line, all the other surrounding lines touching it also got selected. This has never happened before. I’ve always been able to select just one individual line on a layer, no matter how many other lines were touching or intersecting it.

I’ve tried googling around and clicking all the various settings on the lasso tool, but that hasn’t helped.

Then I thought maybe it was a brush setting rather than a lasso setting, so I switched to the pencil, but the same problem occurred.

Then I thought maybe it was just a problem with this particular drawing-- maybe I had accidentally merged the lines. So I drew a new one. Nope, same problem.

Can anyone offer some insight into this? It’s driving me crazy. Thanks in advance.

Interesting update: I can still select single lines (even with other interconnecting lines) on older parts of the animation, but the last three frames I’ve drawn (and also any new lines I make) don’t seem to be able to be selected individually. What is going on here??


You mean the that you can click the line between two points and remove it?
That is only avaible with pen strokes?

I’m not sure what you mean, so maybe it’s better if I illustrate with pictures.

Here you can see, in this frame I drew yesterday, I can still select a single line I made here, even though it clearly touches a bunch of other lines nearby it.

In this image I drew today, with all the same brush settings as yesterday (I believe?), as you can see, when I try to select the top of the sash, it also selects half the arm and the hand.

I have no idea why this is happening. Additionally, if I draw new brush lines over the old ones I drew yesterday, when I lasso them, it still only selects the new brush line when I click it. But if I draw multiple new brush lines, it will select all of them. Does that make any sense?

After further research, I finally found the answer to my question with somebody else having the same problem here:

TLDR somehow the “auto-flatten” tool had gotten activated on the brush settings, but wasn’t showing up as activated on the sidebar. After turning it “on” and then “off” again, it seems to have resolved itself.

great that you solved the problem and good to know if this happens to me too.

There are many settings to change and it’s easy that something is activated but you dont know it.

/ Mattias