Jagged/Odd viewport display

I’ll put my machine specs below.

When I first installed Animate, when I would draw there was a ‘shadow’ on my lines…so bad it even looked like the black lines had WHITE outlines. I was able to resolve this somewhat by adjusting my monitor/settings.

However, while the black lines look fine now, when I draw with another color, even in a high-def document, the lines seem rough/jagged.

This may just be my own lack of knowledge, but this was just opening a document and using the default settings for the brushes.

Should I render the project and see if WISIWIG? I was sort of expecting nice smooth lines…again, this could be just me and my settings.

Environment: Dell XPS - i7 Extreme, Win7 64bit, 12Gig RAM, ATI Radeon HD5870 graphics card.

Thanks,
JT

Dont quote me on this but I think if you go into :

Edit - preferences-OpneGL, and enable Real time anti-aliasing it should make your lines nice N smooth.



you have been quoted ;D

It’s probably just my eyes or something I’m doing - - doing what you ask fixes it a bit, but it still seems jagged…remembering I’ve owned TB for less than a week, here’s a dumb question:

Are the standard paint brush strokes vector/spline constructs like you get with Illustrator or the shapes in PS, or are they just pixels?

The lines that you create in Toon Boom products are always vector lines like in Illustrator. However, when you view the lines with real-time antialiasing on, what it does is it calculates the smoothness based on the size of the resolution of the project. You can adjust the level of smoothness here in the preferences. Go to Edit > Preferences > OpenGL tab. There you will notice you have an entry for Real Time Antialiasing, which the others already told you to enable. You can see there is a field called “Enable at this factor times the scene resolution”. If you set this to a number higher than 1, say set it to 2 or 3, then this will smooth the preview even more.

However, the more accurate that you try to make this preview, the more taxing it will be on your resources. So for heavy scenes, if you have the antialiasing set, you may experience sluggishness. It’s in a lot of cases best to work without antialiasing turned on. You can always do a quick preview of what the frame looks like from the Camera View by clicking on the blue flower at the bottom for Render View - or else you could also do a Render and Play (Animate 2).

~Lilly
Toon Boom Support

I did this, but needed to increase that multiplier as you added.

I’m not too concerned about resources at this point, since my new machine is designed to handle Vue, Zbrush, and 3dsmax without problems.

This seems to have worked fine…

Cool I was going to say the same exact thing Lilly said only totally different. ::slight_smile:
I cannot work with Anti-alias turned off. It makes me sad :’( seeing those ugly ms paint style lines.

What you can also try is a new feature that was added to Animate 2. If you like to work with antialiasing on, and you notice that your system is getting sluggish, then there is a new feature that allows you to make use of your graphic card’s built-in antialiasing instead of using our software antialiasing.

Go to Edit > Preferences > OpenGL tab. Check off the Enable for Real-Time Antialiasing. Now check on the checkbox for Full Scene Antialiasing.

If you’re on a mac, then here in this spot you can enter a number for the samples. It should be a power of two, so try 2 or 4. Then close the program and reopen it, and see whether this looks acceptable to you.

If you’re on a PC, then you leave that box empty. What you need to do now is open up the NVidia control panel for your graphics card driver. Now find where it says something like Antialiasing Mode and set this to Override Application Setting. Then under antialiasing select 2x or 4x. Now reopen the application and see whether the antialiasing looks good. You can set this up for all applications, or for just Animate 2, by browsing to the .exe file for Animate 2 in the Program Files directory.

Hope this helps.

~Lilly
Toon Boom Support