issue exporting anything else but h.264

I am having a weird issue exporting. It seems to want to only export h.264. I select animation and millions of colors+ because I want to export with a transparent background and I select that just fine… but then it exports with a black background, or sometimes gives me a media error and then exports with a black background.
I’ve tried adjusting it within the write node also. Same issue. Any ideas? I’ve tried updating quicktime… sacrificed a goat, etc. I just want my drawing with a blank background! Sigh.

Anyone had this problem of not being able to export characters with transparent backgrounds>

I haven’t had any problems exporting out with transparent background honestly. Alternatively you could export out as a png4 sequence and make a video out of it in media encoder or whatever else you use and use it wherever. Also without seeing the actual project file i cant say what’s happening.

This is the same issue I’m having with the last version of Animate Pro 3 in Windows 10 even after a full Windows reinstall, the codec settings won’t be saved and will always revert to the defaults (which in AP3’s case is the “Animation” codec). (See topic:

The bad news is that I could never fix this so, in order to have the maximum quality for the final render, I had to change my workflow and start exporting image sequences rather than video files.

Is your Windows installation Spanish, by any chance? For the record, my current Windows 10 Pro installation is the US English version, but with Spanish keyboard and regional settings (I used to have the regular Spanish version, which showed the same problem).

I’m having the same issue, plus it seems that I can’t export pictures layout either… I’m having fun thinking about buying a Macbook :slight_smile:

Has anyone found a solution for this yet?

I’m not resorting to exporting image sequences for the rest of my life.

Toon Boom support seem to not understand the issue.

I wrote:
This issue has surfaced many times on the Toon Boom forums.

I am trying to export a .mov with transparency (using the PNG or Animation
codecs), but sadly, Harmony will only export a h.264 codec file. If I change
the codec and settings, it just reverts back to h.264 settings.

I acknowledge there is a workaround by exporting an image sequence, but this
is not ideal by any means.

They replied:

Hi Tim

Please note that H.264 files do not support alpha channels. H.264is designed as a delivery codec: it’s meant to be played. H.264 is not anintermediate codec that there are software packages that claim to do so, but itis being transcoded in the background on the fly.Harmony is using a interface (API) of Quick Time and Quick Time itself does not do this due to many reason. You can find more information from Google aboutthis.

So my suggestion is to use other codec such as animation andput the color depth as Millions of Colour+ to include the alpha on movie export.

Let me know

Best regards, Juho

Yeah, they don’t seem to get it, at all. My support tech kept calling it a bug, but seemed to only understand the part where it populated the h.264 section before I selected something else. He couldn’t seem to get his mind around that H.264 is the only thing I could export. It literally went nowhere.

Exporting with the animation codec, millions of colours + never worked for me either. The file would never open or would say it was corrupt. I always export image sequences for my final renders but sometimes you want to export a quick movie. What I did was install the apple pro res codecs and it works like a charm. Transparent backgrounds, movie, yay!

Hello Tim,

Going by your post TB Support is not necessarily misunderstanding the issue. The support tech in this case did not understand your description of the problem. That only required clarification to move beyond this obstacle in the quest for a solution. Did you pursue this further with Support?

Good luck


Working here in a studio with more than 20 people working on Harmony. At least 3 of them in my team know the same issue.

When they set the video settings in order to export with animation codec, the file is finally encoded in H264.
When they come back to the export window, settings are back to the default value, H264.

It’s happening for one user, whatever the computer he’s using.
So it surely have more to see with users profile, than for example Quictime settings on a computer.

I just create a new user, but it has the same bug with exporting.
It’s really annoying, as we are not able for the moment to use the render network system.

Will keep this thread in mind and post if a workaround is finally found.

So saintjon

for your issue, try to modify some lines in the preferences files, as I mentioned in that thread :

try to locate these 2 lines in the harmony-pref.xml, under usa_db/users/your_login_here/stage/ :

if the value parameter is empty, try adding value for the line VIDEOCONFIG :
value=“OQT(codec(Motion-JPEG A)quality(100)fieldDominance(1))”

I’ll post the second line in a new post, because it’s length controlled…
It should force Harmony to export in Qt, motion codec.

good luck

value=“Enable Sound(true)Enable Video(true)QT(000000000000000000000000000003BE7365616E000000010000000600000000000001AF76696465000000010000001000000000000000227370746C000000010000000000000000726C652000000000002000000400000000207470726C000000010000000000000000000002000000000000000018000000246472617400000001000000000000000000000000000000000000000000000000000000156D70736F00000001000000000000000000000000186D66726100000001000000000000000000000000000000187073667200000001000000000000000000000000000000156266726100000001000000000000000000000000166D70657300000001000000000000000000000000002868617264000000010000000000000000000000000000000000000000000000000000000000000016656E647300000001000000000000000000000000001663666C67000000010000000000000000004400000018636D66720000000100000000000000006170706C00000014636C757400000001000000000000000000000014636465630000000100000000000000000000001C766572730000000100000000000000000003001C000100000000001574726E6300000001000000000000000000000001066973697A00000001000000090000000000000018697764740000000100000000000000000000000000000018696867740000000100000000000000000000000000000018707764740000000100000000000000000000000000000018706867740000000100000000000000000000000000000034636C617000000001000000000000000000000000000000000000000000000000000000000000000000000000000000000000001C706173700000000100000000000000000000000000000000000000187363616D000000010000000000000000000000000000001564696E74000000010000000000000000000000001575656E66000000010000000000000000000000008C736F756E0000000100000005000000000000001873736374000000010000000000000000736F777400000018737372740000000100000000000000005622000000000016737373730000000100000000000000000010000000167373636300000001000000000000000000010000001C76657273000000010000000000000000000300140001000000000015656E76690000000100000000000000000100000015656E736F000000010000000000000000010000003F7361766500000001000000020000000000000015666173740000000100000000000000000100000016737374790000000100000000000000000001)”

this extra long value is to be set in the xml file, for the id=“EXPORTMMX_VIDEOAUDIOCONFIG” parameter

Any ideas/thoughts where this pref file could be, when using a standalone version of harmony?

I did a few searches in the install folder with no luck so I’ve opened another ticket with support citing these threads. It’s obviously becoming an issue -

This started happening in a computer in the office that was working fine until a week ago. A work around was to modify the write module to export movies and use render network instead of render movie. BUT once I exported those settings were again stuck to the one used the first time (same way the export movie settings are stuck in H.264).

I am having the exact same problem after purchasing an upgraded Harmony Essentials 17 desktop subscription.

Just last week I had been using Harmony 15 on my mac and exporting with Alpha channels worked fine, as it has for 6+ years I’ve been using Toon Boom.

After upgrading my Mac OS and being forced to buy the newest model of Harmony, 17 (which is the only one that works with newest mac OS Catalina) I now can only seem to export H.264 no matter what export movie options I select.

Please keep me in the loop, I’ve reached out to tech with my Gold Support and will keep you posted on their response…