Is the bug (Unable to read .tvg) fixed in Harmony 15?


I have a problem with Harmony 14. I copy and paste project folders from one PC to another PC, then I open the copied project and I see a long list of missing elements! Error: Unable to read .tvg files
I did everything to fix that, all naming are correct, saving and copying projects done complete, tried zip or rar, re-installing the software … and I even changed my version of Windows 10!
Nothing worked :frowning:
So, what’s the solution?
And does Harmony 15 have the same problem or not?

After searching I have not found anything consistent with a bug issue.

Errors referring to .tvg files can be caused by several things.

Have you checked the permissions of the files and your capacity as a user on your system?

I have seen where these conflict.

FWIW I have been able to open project files sent to me which were created on other systems. However, I am on OS X.

Would you like to upload the project folder to something like Dropbox and see whether I can open it as a step toward eliminating something on a list of possibilities?

Thanks for your respond
Yes, I guess it’s something about permissions, but i don’t know change what and where!? In harmony preferences or in windows setting?
I have 3 PCs, with same version of windows 10. Main project is on PC 1. I send a copy of it to PC 2 and PC 3. I know my project has no problem because the copy version works correctly in PC 2, but shows this error on PC 3.

You don’t get any error while copying, just when opening the scene and confirmed that all files where copied, original and copy have same size and number of files? Did you copy via your network? Did you try alternatively copying the scene through and external disc or usb pen?

Yes, just when I open the project, all layers are there but totaly empty of drawings. I copy and paste using a usb flash drive. Project size and elements are the same.

Try zipping the project folder before copying it over.
There are many small files in a typical animation project
and it’s likely overwhelming the copy/paste functionality
of your system.

I also tried that and it didn’t work :frowning:
Please please please tell every solution comes to your mind!

Contact support to have a look at the problem on your system
if you’re able to re-create the problem.

I don’t know how to create the same problem! :smiley:
Because it’s a thing that happens sometimes, and not on every system.

It sounds like you have a good project folder. The problem is in getting a good copy of the project which works like the original on other systems.

  1. Try doing a Save As and just add an incremental number to the name. Then move that folder to another system.
  2. Try doing a Save As New Version naming it with something like “NV1” added. Then move that folder to another system.
  3. Try doing a Save As New Version but to a new folder on your desktop. Then move that folder to another system.
  4. Try saving a version from the software using Save As New Version but choose a portable drive as the destination. <= **Of course this is not a good idea in general because it can act glitch while in process and potentially lead to a corrupt save but doing this as an experiment after you have a known backup copy is safe. Just don’t do it routinely.
  5. If you have the systems networked try the Save As New Verion choosing a system over the network. ** Same caution applies.

Thanks for your suggestions, I’ll try them.
I tried saving on flash memory before. The problem showed up again.
This problem didn’t exist on Harmony 10! I guess there is a difference between saving process of TBH10 and TBH14

So,… did anyone find the solution? did it work ?? Because I have the exact same problem.
I’m doing home office right now and my colleague send me my project thru weTransfer. everything is the same and I have permission to read & write but I’m still missing my drawings…