Inverse Kinematics issues

Hi there,

I recently learned about the IK and now want to mess around a bit to become more familiar with it.
In order to that I’m watching the video tutorials from here:

https://www.toonboom.com/resources/video-tutorials/video/inverse-kinematics-basics

So when I grab and move the foot for instance, the entire leg moves accordingly, which is alright. So far so good.

But when I want to do it as shown in the last video (Animating with IK) at 7:35…

https://www.toonboom.com/resources/video-tutorials/video/animating-ik

… nothing happens.
In the video you can see the rabbit bending its knees, that’s exactly what I want my character to do as well, but for any reason I can’t.

My character is set up in a hierarchy as explained in a lot of your TB tutorials (the hip as the upper layer, which contains the thigh, which contains the shin, which contains the foot etc.) and I already double checked that the feet (since I want them stick to the ground) are locked as mentioned in the tutorial as well. Nail and Hold Orientation are both enabled in the tool properties of the IK. I also have IK Manipulation Mode enabled as well as the Bone Selection Mode.

However, when I now grab any of the bones/anchor points of the body with the IK tool, the body barely moves. It’s almost nothing.

Did I overlook anything?

I’d really appreciate any help.

Using the latest TB Harmony Premium.

Edit: Got it. Enable Translation needs to be turned on! :slight_smile:

Okay there’s still a problem. The feet are still moving between the two keyframes, even though I have nailed them.
The position on both keyframes is exactly the same, but inbetween they’re slightly moving downwards and upwards.

How can that be since I enabled Nail and Hold Rotation?

Just in case you don’t understand what I’m saying, here’s a video showing the issue:

https://www.youtube.com/watch?v=R7smopMP6vE&feature=youtu.be

The moving pinned feet has been a known issue for a very long time…unfortunately it’s never been fixed.
I think it’s something to do with the key frame interpolation (3d path or x,y,z position).

Thanks for the reply.
Okay, that’s pretty bad. :frowning:
Is there a workaround without the need to turn every single frame into a keyframe to adjust them manually?

Hmm…

TBH I very much like Harmony, and it fits my workflow very nicely, when doing frame by frame animation or for a hybrid with deformation.
But for purely cut-out style work I always use Anime Studio Pro, it just doesn’t have those sort of frustrations.
So never found a workround, possibly there is one to do with positional keys vs. 3d keys.
But maybe there isnt one at all apart from manually keying the feet back into position on every frame, which kinda takes away the point of cut-out :wink:

To fix this slight movement of the feet, caused by the in-betweens of the rotation,
one has to apply an “IK Constraint” to that frame range:
http://docs.toonboom.com/help/harmony-12-2/premium/cut-out-animation/ik-keyframes.html?Highlight=ik%20constraints

If you like, here are two video demonstrations:
http://www.nolanscott.co.nz/ik_constraints_1.mov
http://www.nolanscott.co.nz/ik_constraints_2.mov
(no sound, it’s all fairly easy and straight-forward)


www.nolanscott.co.nz

“It’s not a bug, it’s a feature”:smiley:
No seriously, this is amazing, works like a charme. Wow!
Thank you so much for your help!
Now I can finalize my animation.

It’s good to know they have now improved this part of the ik system, something I wasn’t aware of…