Improve appearance of Auto-matte

Hi, I’m having a bit of an issue trying to use the auto-matte feature in conjunction with textured vector brushes.

I’ve attached an image showing my issue.
I like to draw with a vector brush with a texture that makes it look more like pencil.
But the issue is when I generate and Auto-matte it extends past the edge of the visible stroke.
I understand why. It’s going to the very outside edge of the vector region that the pencil stroke gets drawn inside.

I can use the eraser to erase the edge of the matte down, but that’s very time-consuming.
I’m wondering if anyone has any ideas for how I might automatically contract the auto-mate layer.
Is there a way to do this with a script or something? Either in SBP or even photoshop?

In the future, it would be nice if the automate feature had an option to be contracted slightly when it’s generated.

Thanks for any ideas people might have.

Same issue here.