importing images in Harmony

I just had to upgrade to Harmony from Animate Pro because I needed to send files for color to another studio. I’m new to both programs. When I was using APro I was able to follow the tutorials and import an image as a pan and it fit into the window with the sides extending just as I expected it to. Now in Harmony it keeps importing this same BG way beyond the edges of the camera in all directions. I’ve tried importing with all the different settings (vector, bitmap, symbol, etc) but the same thing. What am I doing different? I have a Mac and the very latest version of Harmony was installed this morning.

OK. I can see that it’s fitting to the drawing grid. That’s probably why it was working as a pan in Animate Pro and not in Harmony. Originally this project was using NTSC 4:3 ratio which fit the drawing grid. Now, however it’s been changed to HDTV, 16:9 ratio, I’m using Harmony and I’ve redone all my BGs and Layouts to accommodate.

BUT, I don’t see anywhere in the scene setting dialog box where I can set horizontal OR vertical fit. I have it set for HDTV, square pixels. Is there a way to change the drawing grid for HDTV? I’m doing an 11 minute traditionally animated film with 68 scenes, a number of them are pans. I’m importing layered Photoshop images. The non-movement scenes fit perfectly when I use the fit option, but I need to make the pan scenes work too. Most are horizontal pans, but there are a few vertical pans and at least one diagonal pan.

I think I solved the problem! In the scene setting box under alignment, I changed the units aspect ratio to 16:9 and voila! The drawing grid and my BG pan are now fitting to the top and bottom of the camera! Yippee!!

Now I hope this works when I get to a scene with a vertical pan … or that darn diagonal one.

Also, I’m wondering if I can make this the default or if I’ll have to make this change manually in each of my 68 scenes? If I’ve set everything up to ToonBoom’s presets for HDTV, why wasn’t this aspect ratio for the drawing grid part of the preset?

I am on a new iMac i7 with Snow Leopard, running Harmony

I tried to make the changes you suggested to the resolution.conf file but when I tried to save it, it said this was a read-only file and I’d have to rename to save it. I was hesitant to do that.

Since I was told Harmony was basically the same as Animate Pro with the addition of networking, I looked first to the forums for answers. I will address further questions to TBsupport.

It’s most likely due to the “Fit” of the scene. When you import an image into the scene, it will either fit it vertically or fit it horizontally. When the image is imported, it will bring it in with relation to the Drawing grid (so if you did a View > Grid > Show Grid, it fits to that grid). If the drawing grid extends outside your scene then depending on the fit, it will bring it in larger than the scene.

Turn on the drawing grid first of all. Notice that if you have an HD scene, for example, because it’s a widescreen aspect ratio, the drawing grid extends above and below the camera. Now if you import with Horizontal fit on, with the Pan setting in the import images dialog, it will import it larger because it will fit to the top and bottom of the drawing grid. So you probably want to set your scene to Vertical fit - which you can get to through the scene settings dialog.

I hope that makes sense.


Generally Harmony-related questions should be addessed straight to - now in order to be able to help you further I’ll need to know some more information about what version of Harmony you are using. Usually the solution here would be to go into your resolution.conf file and update that file with the appropriate fit. Now by changing the alignment, although that has solved your issue, I am not sure whether this is something that can be copied from one file to another - you might have to do that in each scene. But if you edit the resolution.conf file to do vertical fit, then it should update this on the scenes that use that resolution.

The resolution.conf file is located in your application folder, > tba > etc (are you on Mac or windows? The path might be slightly different on windows). If you edit this resolution.conf file, next to HDTV you will see an H, you can change this to V.


The read-only error is normal. What you would have to do is copy the resolution.conf file onto your desktop. Get the rights to save it and save the file there. Then you can back up the original resolution.conf file by renaming it something like resolution_bak.conf so that you can always get it back again. Then drag and drop the new copy from your desktop back into that folder.