Importing Illustrator file with layers - no layers show

I’m importing an Ilustrator file with layers but no layers show. Why not? I have to be able to switch layers on and off but as I can’t see them I can’t do this.

All the individual objects are selectable.

Make sure to check “Preserve original layers of Illustrator documents”…

Otherwise…
Try Toon Boom Animate 2 and use the script importing Illustrator files on separate layers.
http://www.youtube.com/watch?v=NetQNRVBwOA

Be aware to save your Illustrator files in “Legacy Format” and make them PDF compatible…

Thanks so much.
I’m using Toon Boom Studio.
I have checked the ‘Preserve layers…’ check box.
How do you save in ‘Legacy format and make the PDF compatible’?

Well, I presume, depending on the Illustrator version you’re using…?

Either…
File / Save As… from the Illustrator Options check Create PDF Compatible File…

Or…
File / Export… from the Export window Format choose Illustrator Legacy (ai)…
From the Illustrator Legacy Options window Versions choose Illustrator 10 / 9 / or 8…
Not sure if Studio even supports earlier versions of Illustrator…?
From the Options check Create PDF Compatible File…

Thanks again…
CS6
No Options check in Save as, only Save as type - and under that no Adobe PDF compatible file
No Illustrator legacy in Export. No PDF compatable file there either

Can’t check it out, still using Illustrator 11…
But I am quite surprised that one can’t save or export a file from Illustrator CS6 to any of the Legacy Formats…?

quote:
In Illustrator, when you save a file it asks you which version you want to save it as. Instead of CS6, you can choose a “Legacy Format” like Illustrator CS5, CS4, CS3, etc. – but be aware that you may lose some newer features and attributes when the document is read back in to the prior release. Illustrator actually has the best compatibility of all programs as it can save back up to ten previous formats
:quote ends

Those sort of options come up when saving as an Illustrator EPS but nothing comes up when saving as Ai

Oops…the Illustrator options come up after pressing save!!!

So…I tried saving as cs5, pdf compatible, imported…but the layers still don’t show

Are you able to save as Illustrator 8, 9 or 10…?

Thanks for your help Nolan…appreciated. the layers turned up when I saved as v12 CS2 (which I also have a copy of).

PS. I’m Kiwi also :slight_smile:

hmmm…I’ve upgraded to Animate 2 and now find I can’t import Illustrator files and retain the layers.

nolanscott said (2nd post) :

Otherwise…
Try Toon Boom Animate 2 and use the script importing Illustrator files on separate layers.

How is that done?

Well, first you need that script “importing illustrator files on separate layers”…

Then copy and paste that script as explained in the video…

When you hit the script button and select your illustrator file, a new directory-folder “name.tpl”
will be created at the same location as your illustrator file…

Open that folder and double click the “scene.tbup”” file…
This should open your illustrator file into separate layers…

If you can’t find that script, try this link:
http://www.nolanscott.co.nz/illustrator_import_script.pdf

Regards
Nolan

ummmm…What video?

And where is the script - normally - as oposed to the link you gave?

The video in post no. one and nine
http://www.youtube.com/watch?v=NetQNRVBwOA

The script was published by Lilly Vogelesang, Product Manager at Toon Boom:
https://forums.toonboom.com/toon-boom-animate-family/tips-and-tricks/importing-illustrator-files-ai-with-layers
(post no. eight)

The link to the Illustrator-Script was set-up for your convenience and easy access only…

hmmm…must be blind. I have the script but can’t see the video…

Don’t know how to use scripts so need instructions. Lily at TB support says: ‘Run the script…’

ummm…how do you run the script?

What kind of system are you using, not to be able to watch a youtube movie…?

Check out the Animate Scripting Guide, Chapter 1, Scripting Introduction…
It’s all there what you need to know…
http://beta.toonboom.com/professionals/animating/resources

See post no. eleven… and Lilly Vogelesang’s explanation…

Hi Nolan,

I seem to remember you posting something about the AI script not working properly under the new Harmony build – can’t seem to find that thread with the new forum update. What was it I needed to change within this script to make it work under Harmony?

Thanks,
14g

Apparently, the script should work in Animate 2, Animate 2 Pro and Harmony…?
Have you tried the script from my post above…? (post No. 11).

Otherwise, you might contact Lilly Vogelesang at Toon Boom directly…
http://ca.linkedin.com/pub/lilly-vogelesang/6/356/531

Regards
Nolan

Opps…sorry. I couldn’t see a video…but needed to hit ‘See Content’ button…can now…

So…I watched the video…
Opened ‘Edit Scripts’ in the Scripts toolbar…
Created a new Script - ‘Ai layer import’…
Opened it and pasted script…
Closed window…
Opened Manage Scripts…and behold my new script is not there, and some of the scripts that are there are not the same as showed in the new Script window…AND there is a script there that in called ‘Import Illustrator’…which sounds like what what I am trying to do - maybe…

So I don’t know what is going on…where my new script has gone…