Importing .AI and .FLA into Harmony Premium 12.1

I’m unable to import Illustrator .AI or Flash .FLA files into Harmony Premium 12.1 on Windows, using the following process:

Get Rights to Modify an asset library
Select Import Files from the right click menu in the Library window (or use the File menu)
Select the .AI file to import
I see a box with a progress bar, where the amount of time taken is directly proportional to the complexity of the file I’m importing)
Then nothing happens. The progress bar window goes away and I have no files in my library.

My files are saved correctly and I’ve tried multiple versions right done to Illustrator 8 (I’m using Illustrator CC). The files are RGB and have no gradients or textures, just linework.

For .FLA import, I’m using the built-in importer from the scripts toolbar and get a similar result. The difference here is that the nodes are all being created, but the elements contain no drawings. I know it’s reading the contents of the .FLA file as the nodes are named the same way as the layers, but there aren’t any drawings at all. I don’t see any in ToonBoom or on the server where my scene is saved to. I’m using Flash CS6.

I am able to make templates manually (copy nodes, paste into library) so there doesn’t seem to be an issue with actually saving to the server.

Does anybody have any guidance on this? It’s really frustrating that something happens (seeing the progress bar actually progress) but then having no resultant files.

Thanks!

Good evening,

For AI files, they also have to be RGB. CMYK is not supported (just a side note in case).

Does your Flash or AI file contain advanced filter effects or gradients?

If you try with a file with a simple painted circle, do you still experience the same issue?

Marie-Eve

Hi Marie-Eve

The files I’m trying are all RGB and contain no gradients or filter effects. They work perfectly on some computers but not on others, so I know the files are not the problem. I have tried with a simple square, a simple circle and a simple straight line and still have the same issue.

The hardware and OS versions are pretty much identical. I have uninstalled and re-installed Harmony on my workstation to see if it was an installation issue, but that did not resolve it.

Thanks

David

someone has a solution to this problem, and I have one week struggling with this problem and can not find a solution, someone who can help please

You should probably contact support to have a look on your system or to examine the files
if you’re stuck.

Hi thumpa,

This is strange indeed. I would then recommend to contact our Support team as it may be a hardware issue.

https://store.toonboom.com/contact/support

Marie-Eve

There is an extension for Flash to allow you to export FLA files into a ToonBoom-ready format. Neither that nor the SWF importer works.

The files I’m trying to import are good - they work just fine on an identical workstation for another user. I’ve even re-installed ToonBoom and it still doesn’t work for me.

You can import SWFs but not FLA files from Flash into the Library.

For the illustrator files, they must be saved in Legacy mode to be compatible
with Illustrator 10 (pre-CS) and it should work. If you’re still having trouble,
contact support and send them your Illustrator file for analysis.

I’m having the same problem as him.

I’m using Illustrator CS6
Toon boom harmony 12

My files doesn’t have spaces, accented and special characters in the filename. I’m following exactly what is saying here.

http://docs.toonboom.com/help/harmony-12/premium-network/Content/_CORE/Workflow/025_Import/012_H1_Importing_AI_and_PDF_Files.html

But i’m stuck up in the third step!! My dialog box to rename my file doesn’t appeared like is saying because after importing nothing else happened.

  • First step OK
  • Second step . File > Import > SWF, Illustrator files to library. OK / Right- click on any unlocked folder and select IMPORT FILES
    ( I did right-click on stage library and choose my file but then nothing happened)

Am I doing something wrong?