Imported Images look like they are super blurred.

I am working on an animation and when I import hte background image, which is rather large, it comes in very blurred. How can I fix this? I can make is .psd, .jpg, .bmp .tiff .targa and still get the same result. Please help.

“When one imports a bitmap image into a scene, a smaller version of it is created by the system in order to accelerate the compositing and playback process.”

Either one has to render the view…
Or open the Preferences / Camera / and increase the “Small Bitmap Resolution”…
(maybe start with 1024 pixels or higher…)

What is your original image-resolution…?


I just want to add to Nolan’s helpful 6 years old advice that you have to restart the program to see the resolution changed in the OpenGL preview.

Best regards,