Import Swf,PDf,Ai Problem

I can import everything that is supported except for swf,pdf and ai files. I followed the direction in the manual.
Right click on “Animate Library” and press “Right to modify” then import Files. After I choose the file, a loading bar appears. It’s seems as if it imported it. But the library is blank. So is my layer panel, I tried creating a new folder within the Animate Library. And import their, still nothing happens.
What am I doing wrong, cause this is getting very frustrating.
My swf movies are from from Adobe flash cs4 and my .AI files are from Illustrator Cs4, I even tried saving the .AI as Illustrator CS, still didn’t work.

App: TB Animate
Win Xp pro x64
Dual core 2.2 GHz
2GB Ram

The Illustrator image must be saved in legacy compatibility mode with Illustrator 10 and the SWF needs to be saved in Legacy compatibility with Flash 6. Both have features used in the newer versions that are not compatible and have not been made public.

Thanks a hoot, you’ve made my day. ;D

I still can’t import swf to Animate. I’ve made a symbol in Flash, changed publish settings to Flash 5, generated swf-file. Then I select File → Import swf to library → progress bar appears, but then nothing happens. :frowning:


Are you using the full version of the PLE? The import is actually disabled in the PLE.



I use PLE :slight_smile: Thanks

Was a solution found for this? I am having the same issue. After importing SWF (exported from Illustrator as legacy) it seems to import but nothing appears.

Converting AI vectors into rasters then redrawing in Animate is obviously ridiculous so if anyone can help get swf in that’d be great.

I would hope the next edition of Animate rectifies this (ie: just import SWF like everything else instead of confusing the user)… “Right to Modify” etc just to import vector graphics is bad application design. Let me just make cartoons.


The import pdf/swf is actually disabled inside the PLE so it is normal that it does not work. If your issue is in the full version of the software let us know though.



Hey, Ugo. I’m having an issue where the import swf setting seems disabled in the full version. Any idea what would cause that? I’m really not sure what to do. Any help is appreciated!

first read the full thread please, then ask. the answer is in the first posting.

Using Animate Pro (AP), and CS4 Master Collection. I don’t have any problems going from AI files to AP, except none of the items are one unit, every stroke and fill are independent of each other, don’t know if AI or AP issue, will play around with it. I haven’t tried the legacy version to see if this remedies the independent items.
As for swf, yeah, nothing is shown even after I give “right to modify”- can anyone tell me why this has to be done every time I open AP, or any project for that matter. I see all the layers but not any images. I even have exported out version 6 swf, will see if any of the other swf versions work but I have already lost tons of work that I had created in flash.