Import pngs for drawing reference

I imported a series of animation frames as png’s so that I could have them visible when I do a similar animation. But because I imported them they aren’t drawings and don’t show up when I go to Drawing view. Do I have to do my animation in camera view because of this? Or is there a way to see the imported drawings in Drawing view?


Show Light Table (shift+L)… or check the Lightbulb in the Toolbar…


Thanks Nolan but that only worked in Camera view. It’s still hidden when I go to drawing view.

Hmmm… works perfectly here…

Import your image sequence or movie-file…
Create a drawing layer just above the image layer…
Switch to the Drawing View…
Select the first cell of the drawing layer…
Tick the lightbulb icon…
If you like, open the Preferences / Drawing / uncheck Light Table: Enable Shade…

Which version of Animate are you using…?


I believe I might have imported them as a symbol. It’s been a few days and I’m still new to using Animate so that might have been what I did.
Thanks Nolan and Lilly!

I always have problems importing PNG image sequences, sometimes they don’t import in order , i click on the first one and shift select the last . or i do it in the Opposite , last to first . sometimes works some times not . i hope someday they software can organize the sequence by selecting only the first one , and gives the option if you want it as sequences or just one image . as seen in some applications .
Hope this will be fixed in the next versions .

i’m using Animate pro 2 . i actually find the same problem a while ago with digital pro , i used the ple then .
It’s just sometimes does not import them in order .
I just have to re-import them over and over until i get it to work right .

I just wish it’ll be like in AE , you just select one pic (First frame) and other’s will follow , and have a check box that asks if u want to import as sequence . or one image .

Thanks Lilly .

Just make sure that you don’t import your drawings into a symbol. Symbols won’t show up in the drawing view. If you have imported your drawing into a symbol, you can select the symbol layer then go to Edit > Expand Symbol. Drag the expanded drawing layer so that it’s unparented from the original symbol then you can delete the symbol.

Or you can just re-import and uncheck the option to create a symbol out of the layer.


James are you using Animate 1 or Animate Pro 1, or Animate 2 or Animate Pro 2? I’d like to try to reproduce your problem here.


Hi James,

Well I ran some tests here on my Mac and I tried importing a variety of png sequences and I had no problems. Can you tell me:

- What operating system are you running? Windows or mac?
- When you import the images, are you vectorising them? If so, with which option? I don’t think this should make a difference but just in case
- What is the naming convention on the drawings that you’re trying to import?

Best thing actually would be if you could send me some images that don’t import in the right order. You could email me at and send them to me or I can set up an ftp for you.