Import an SWF file in to Animate.

Hi I am new to Animate. I have tried to import an SWF file in to Animate.
I have followed the directions to the letter with no success. I am not sure if it’s because I am using Flash CS4 Professional? My question is did anyone else have this problem? If so please tell me how you imported in?

Thanks in advance.
Jim Allen


I have made a simple test to import a SWF file in Animate. I created a new document action script 3, I drew a rectangle, create a keyframe at 25 tables by moving a little. Then I created a classic tween. I have exported as SWF movie.
Then, in Animate, I went to library, Animate Library, right click / Right to Modify. Then, on the right library window, right click / import files and browse the SWF. The file has been imported into the library as .tpl (template). I’ve dragged to timeline in the normal mode, and the template has appeared as a peg with a keyframe by frame to define the path, with an indented layer containing the drawing.
This simple test has worked correctly, you should try different methods of CS4 file to check if everything is working well. Best Regards.


Ok maybe I wasn’t clear. I can get the SWF file to import in Animate as a (tpl file). It shows it there when I drag it to the time line all I get is"GlobalFlashPeg” with a “+” sign that’s it. I click on the “+” sign and all of the dropdown frames are blank. It has Position: X Position: Y Position: Z Scale : X Scale : Y Angle Skew. All of them are blank.

P.S. Are you using Flash CS4 Professional?

Thanks again

Yes, I´ve used Flash CS4 Professional for this test, but I don´t use Flash CS4 currently.
In this test, when I dragged the .tpl file into the timeline I get a "GlobalFlashPeg”, indented it, other peg named as the SWF plus p-00 suffix, indented to it, other layer (drawing element) named as SWF file. These elements shows the same exposure as the original SWF.
Have you tested reproducing this example? The "GlobalFlashPeg” shows a serie of outined dots when collapsed? Are you clicked on the left arrow to show the peg contents? Nothing happens if you click on the + in this peg. Only the indented elements shows the parameters of each one when you click on +
To reproduce the test remember that I created a document action script 3, 25 frames lenght, classic motion tween. If all is normal you would get the same results that me. (quote: I worked on Animate 1). Maybe it works.

Try exporting you SWF file to Flash Player 6 or 7. This solved a similar problem for me.

Graphical_Jack your the man!!
Thank you so much. I did just as you said and that did the trick!!
It imported just fine!! ;D