Illustrator import into AnimatePro- layers lost?

hi,

i am unable to import any .ai file with layers intact. It always is flattened.
(no triangle to unfold in the timeline)
I did everything according to the manual and it behaves as it should according to the manual (palette recovery, little “+” when dragging to timeline), but still…layers are flattened :’(

i tried to save as illustrator 8,9,10,cs1,2,3,4. with different options checked/unchecked. Either it results in nothing being imported (empty drawing)
or i get the flattened image without any layers :frowning:

I don’t have (nor ever had!) the PLE installed, so no possible conflict there.
i do, however, have the old digital pro installed (where it worked!)

In Illustrator the layers are definitely layers, NOT sub-layers.

As you can tell, i tried everything i found in the forums so far - still no luck.

So i’m at a loss as to what to try next. ???
ANY hints highly appreciated!

Thanks!


We will look into this but in the meantime since you have bothe Digital Pro and Animate Pro, create the template in Digital Pro, then import the template in Animate Pro. Remember to save the Illustrator file in Legacy mode to be compatible with Illustrator 10.

Another workaround if you don’t have access to Digital Pro is to “hide” the
layers in Illustrator to export each layer as a separate image to be imported into Animate Pro.

Thanks,

but i have to send the digital pro dongle back (i upgraded to animate pro recently), so
this workaround soon will become a non-option. As i mentioned i tried all legacy modes available in illustrator. Saving everything seperately works (thanks for the tip!), but still it would be much nicer/faster if it worked outright. I do have to handle LOTS of background elements…

thanks again!


hi,

any updates concerning lost layers on .ai import?

thanks!

Under File/Import/SWF,Illustrator Files to Libaray, unable to select at all, it in a in grey, prompting not selection for this.

any one can help me with this?

http://www.toonboom.com/support/forums/animate/index.php?board=16;action=display;threadid=1089

hope it helps.
rob