I don't know how my Offset Shadow is break into parts in final render?

i think there is something with the Composition but i don’t know which setting to change it

Just have the 2 connections coming from Rick_1 instead of Composite_1 which is not needed.

Looks like you have overlapping drawings/artwork, you should try selecting it all and then Flatten it.