I can not erase a mark of pencil on my animation.

It’s quite simple : I have my frame, and a drawing on it. Next to my drawing, I saw some marks of pencil…I try to clean all that and…Impossible ! There is parts of my drawing that I can erase and an other part (it’s just a point next to my drawing luckily) that I can not erased…

I checked my “Layers” and I didn’t make any mistake, so…Unfortunately I don’t know how to erase these flourish, can someone help me ?

Can’t the eraser erase everything ? Did I missed something ?

You mentioned layers. Do you mean that you checked the Underlay, Colour Art and Overlay layers?


Yes, that’s exactly what I meant !
I checked all of that, but nothing work…The mark is on the same “layer” where I’m trying to erase but it do not erased…

Are you able to select the shape that the part you are trying to erase it connected to?
(using the selection tool)

Try erasing the drawing part from the Drawing Window instead of the Camera/Stage view.

No, I’m not able to select it !

And I tried but I can not erased it because when I open the Drawing Window, the mark isn’t here anymore…But I still see it on the Camera Window !
Is it a render issue ?

Try zooming out in the drawing view and do a “select all” maybe
it’s somewhere off-center.

I tried…And nothing ! It’s really strange…It seems that the mark doesn’t exist, but when I exported my animation to check, the mark was here again.

I am just another user.

If you want I am curious and would like to check out this line in your file if you care to upload it to something like Dropbox.

Or you could send it to Toon Boom and have them look.

If you are concerned about private content you could make a copy and delete everything inside. Chances are you might delete the location of the line you cannot erase in the process so do it methodically paying attention to see whether it deletes with a drawing. It might solve your problem in the process.

I’m having the same issue as the user above.

When I click on Drawing view, as opposed to Camera view, the lines I wish to erase disappear. I don’t know how to erase only a couple of lines (which I drew earlier).

In TvPaint there’s a setting that allows your ‘ink’ to dry. I wonder if this might be the underlying problem…

I know this is an old conversation, but I just had this issue and realized the solution and I wasn’t able to find anyone else answering it.

My issue was that I had drawn the drawing when the layer was set to bitmap, and then I had changed it to vector. It seems that you can’t erase a bitmap drawing in vector mode even if it is the same layer. Once I changed the layer back to bitmap, I was able to erase like normal. I’m sure it would be the same situation vice versa.

To change it back: right click on layer->layer properties->drawing->set line art type to bitmap or vector respectfully.

I hope this can help someone :slight_smile: