How to turn off anti-aliasing? (Renders look blurry and shaky)

I’ve been using Harmony Basics for a while now, but I’ve had one persistent problem.

When drawing, my animations look pretty nice. The jagged edges are cool and the lines look fairly smooth.
However, when in render view and while rendering, the lines appear blurry and shaky, despite not looking this way in preview.

I’ve looking around for a while and have been unable to find a solution for this. I’ve tried turning off Anti-Aliasing in the OpenGL menu, but to no effect. It still looks the same either way. As for the shaky lines, I’ve still yet to find anything regarding that. They appear this way even when using Smoothing on brushes.

I would really appreciate if anybody could help out with both these problem. Thanks!

Links:

Preview 1:
https://i.gyazo.com/5c056cd19d1475b4d7bde9fc93be94ff.png
Render 1:
https://i.gyazo.com/fa161cfa270903ae7264061228116b5b.png

Preview 2:
https://i.gyazo.com/aadf4facda28c4c1c2c93e5aed655c4a.png
Render 2:
https://i.gyazo.com/8c31d510a29cb5234ffd3a38b2f1338e.png

What resolution are you rendering the images to? A higher resolution will have more information (finer pixels) to produce cleaner looking lines. Low resolution will have relatively large pixels so when the lines are antialiased the halftone pixels will be more apparent and the lines will look blurry.

The blurriness in the lines is antialiasing in effect. Generally, it is common to described aliased lines as “jagged” and antialiased lines as “smooth.” So “jagged smooth lines” probably means something else like the actual arc/curve of the stroke…maybe?

To me at least, your choice of words to describe what is happening and what you want are confusing, (“shaky” and “jagged” and “smooth” particularly “jagged edges are cool and the lines look fairly smooth” is a contradiction). The linked images really need specific text pointing to what exactly you are referring to in each because given your words each image could be taken different ways.

What do you mean by “shaky” lines?

A. The arc/curve of the stroke?
B. The characteristic of the line edge itself?
C. Other

What do you mean by “jagged” lines?

A. The arc/curve of the stroke?
B. The characteristic of the line edge itself?
C. Other

I usually render in 1920x1080.

I prefer the aliased lines, as the pixelated style suits what I’m animating.

In terms of my word choice, let me clarify.
I would like to make my lines aliased, but, despite my having turned off anti-aliasing, it still appears this way.

My describing the lines as shaky is that, in rendering, it looks similar to when pressure sensitivity is disabled on a tablet. You can see this in the rendered previews I’ve shown in my original post.

Regardless, the shaky lines is less of an issue. The primary issue is the anti-aliasing. I would just like my images to render and look just as they do when I’m drawing them in the Open GL view.

Sorry but I still don’t understand the “shaky” concept.

Turning off pressure sensitivity on my system just produces consistent line thickness but otherwise identical line behavior to that with pressure sensitive variances.

Taking everything into consideration I am leaning towards suggesting that you experiment with the smoothing slider inside Tool Properties that offers control over arc/curvature of strokes as something to explore.

Aliased lines are less noticeable with higher resolution because the aliased jagged edge is directly related to pixel density.

Can you work with a lower resolution?

Well the issue is less with the resolution and is more to do with rendering in general. Is there not a way to just render it as it appears in OpenGL view? Because, regardless of the resolution, the program keeps anti-aliasing the lines.

This is a canvas at 500x500.
OpenGL:
https://i.gyazo.com/7cc74a4aac8bdad75457e976b3e81617.png
Final Render:
https://i.gyazo.com/55988f948f5c6d7350f2e94805185cdd.png

All I want to do is render the OpenGL images rather than the full-quality render versions.

There is a way to do this in Toon Boom Animate 3, and maybe it is the same for Harmony:

In the timeline, right click on the name of a layer and then choose “Layer Properties.” In the popup box, choose the “Advanced” tab. In the pulldown menu next to “Antialiasing Quality” choose “Low.”

I’ve seen this before.
Here is what layer properties are in Harmony:
https://i.gyazo.com/1f48d8336395c8569d19552b1998c4f9.png
Maybe I’m missing something, but most likely, this isn’t an option here.

Yeah, looks like the option is gone. I wonder if there is a node for adjusting the antialiasing?

I switched to Anime Studio/Moho because the lines look so much better - crisp but not jagged. The antialiasing was a real issue for me in Animate 3. The “Low” setting was too extreme, but the next level was too soft.

I’m considering Toon Boom again because Moho’s future seems to be a bit shaky right now. I do hope Harmony has a way to tone down that antialiasing.

I’m sure it does. I’ve seen people animating with it who have amazing results, often without the damn blurry lines.

Hopefully I can find a way to fix this dumb issue.

The OP is using Essentials. Only Premium and Advanced have the advanced tab under Layer Properties. Only Premium has Nodes.

Do you want sharp crisp smooth lines or sharp crisp jagged lines?

.

The option exists in Premium (12.1.1) under: File => Export => OpenGL Frames.

I do not see this in the Essentials 14 documentation:

http://docs.toonboom.com/help/harmony-14/essentials/export/about-export.html

If you were able to generate a PNG of the OpenGL representation without making a screen capture just produce image sequences of the OpenGL screen and assemble them in a video editor. Free VE’s are available.