How To Improve Performance?

I wonder if there is a way to improve performance of Animate 2 Pro so it works as smoothly as Toon Boom Studio when it comes to drawing etc. I turned off antialiasing and I own a Dual Core processor with 2gb of ram.

If you’re using Windows (not sure how it is on Mac) you can open task manager, then under Processes tab find “AnimatePro.exe”, right click and set the priority to High. This cheap tick fastened my rendering from 45mins to 7-8mins when I was working under a deadline.

Also, try closing other programs which may be slowing the performance down (not just obvious ones like your music player, e-mail, but also “little ones” you may be using - downloads, IM messengers, apps like Dropbox → many programs stay open and waste your memory but are not shown on the main task bar).

my graphic card is NVIDIA GeForce 9800 GT

Turned off the aero theme and changed the priority of Toon Boom to ‘Real Time’ and now drawing is much smoother, better, faster… (stronger?)


Thanks a million for all your help.
You’ve improved my motivation for animation! :slight_smile:

PS. Is Aero really what causes the lag? I’ve read it’s less demanding ram-wise and boosts performance more than the classic win7 theme.

Yes I think it really is Aero. I’m only a few months on this forum and I think I allready saw the same problem 4 or 5 times. Everytime the solution seams to be the Aero theme.

are there any other ways of improving performance? Is there even a way to make it as smooth as Toon Boom Studio or close to it?

Hello again. I got no reply from support@toonboom so I was wondering if getting a quad core processor would improve the performance. I know it would speed up the export process and I could maybe work directly on render view but what about drawing? What could improve the OpenGL on my pc?

Hello,

Can you tell me exactly when you sent your e-mail to support@toonboom.com ?

Also, what was the exact subject line ?

Please, let me know


Francois

I sent it exactly on 29.07.2011.
the subject line was simply "I need help with improving performance in Toon Boom Animate 2"

thanks for the quick reply, I only just saw the message here.

If you’re on Windows Vista or 7 then you should also turn off the Aero theme. Right-click on the desktop and select Personalize, then select a Basic theme instead of Aero.

What graphics card do you have?

~Lilly

That graphics card should definitely be sufficient for working with OpenGL. Did you try turning off the Aero theme? Did this help?

~Lilly

Aero theme can also interfere with OpenGL, and causes problems being able to pick properly with the transform tool. It can also cause a lag when you draw a stroke. I don’t know why under the hood it causes these problems, I just know that it does. :slight_smile:

~Lilly

Well the real difference between Studio and Animate is that Animate relies more heavily on OpenGL for display. With a 9800 graphics card, though, you should be okay. If your scenes get very long, though, you’ll see slow down. Or if you’re using lots of strokes.

If you write in to support@toonboom.com, perhaps they may have some further feedback.

~Lilly

I have asked support to take a look at this thread - I’m not sure why they didn’t respond, perhaps the message never made it through.

Improving your processor will definitely help when it comes to rendering, but I’m not sure if you’ll see a lot of improvement in OpenGL. Let’s see what support says when they chime in. 8)

~Lilly