How do you make certain to select the intended element?


Bit of an awkward title to this topic, but what I am having difficulty with is selecting a pegged character within a scene to move it without accidentally selecting another.

For example, I have my camera attached to a peg, and I am using the motion tool to place key frames for panning the camera in and out, or from side to side within the scene (e.g. closeups of characters, what have you). I need the other characters, backgrounds, etc. on the screen so I can use them as reference to position the camera. However, when I cannot tell which of the little brown camera marks on screen is the one for the camera. Whenever I try to touch one with my pen, I inadvertently grab another element, like a background or another character. I tried using the overhead view (that shows the elements as green lines on top of one another) but the little cameras are all so close together and overlapping that I cannot tell which is the one I need to touch. It doesn’t make a difference if I have peg-only on or off. I assumed the red circled camera was the one indicating the highlited (selected) element, but this is not the case. Everytime I am successful, it is only through random trial and error until I grab the right one.

Also, I thought that the select tool (the one with the black-square cornered bounding box) was the tool you are supposed to use to nudge things forward or backward in z-space. I was told to select the element in question with this tool, then while holding command/alt to get the double arrow use the up/down arrown keys to nudge forward or backwards. This does not work. I can change forward/backward doing this same thing with the motion tool, but not with the select tool. With the select tool, nothing happens at all, unless I touch the part in question with my pen and move it slightly in x or y space first. Doing this seems to activate the double up/down arrow and I can then change the z-space, but I have to press control-z to get it back to the correct x and y position first. This seems odd. Clearly I am doing something wrong here. Why can I not get that up/down arrow key? I tried command/alt, shift/alt, option/alt, etc. Nothing works.

In summary then: How do I choose the intended little camera for the right element I want to move with the motion tool? And, what is the most efficient way to change something in z-space? Is it better to use the motion tool? I guess I am asking this because if the select tool doesn’t work for this then I don’t understand what it is for.

Sorry for all the questions, some which may seem very repetitive.



Sorry, I should clarify, when I say “which little camera” I mean which little brown box with the arrow next to it (I know they are not cameras, but they kind of look like cameras).



The best way to select only the elements that you want in the camera view without hiding any layer is to Lock the layer. If you right click on the left part of the timeline you will see some commands relating to locking layers.

A locked layers will appear in red in the Timeline and will not be selectable in the camera view.

After locking the layers that you do not want to select, selecting the others should be easier.

As for your other question, the Sceneplanning Tool’s purpose is to transform a layer the same way over every frame (no animation). Moving in Z direction is one of the transformations possible. It was suggested for shifting objects in Z because if you do it with the Motion Tool and create keyframes of Z motion it might create an animation and change the Z over time which you probably do not want.

The issue that you have with the select tool no shifting in Z is probably due to the fact that the camera window does not have the focus when the shortcut is pressed. This is tricky because the camera view needs the focus to activate the shortcut so you need to click inside it after clicking in the timeline to select the layer.

The best way I have found to give focus to the camera without affecting anything is to Click on the blue pivot point to give the camera view focus. This blue pivot point appears when the Select Tool is active and a Drawing or Peg layer is selected.

Hopefully this answers your questions.


Thanks for the explanations. I will try these.

Always appreciate the quick help.


Simon hi,

I tried your suggestions, and locking other elements is a big help in selecting the intended one, however, I am still having problems.

One problem that I am having now is that keyframes on my camera peg are affecting earlier keyframes (shifting the camera view at those frames).

I have the camera attached to a peg. I achieve zoom, panning, etc. by placing a motion keyframe at the point I want the view to change, and moving the camera around in X, Y, and Z space. This has always worked before.

Now, however, for some reason when I create a new keyframe and move the camera to the new position, earlier camera positions are changing. The keyframes are constant so there should be no movement between them let alone at the earlier keyframes themselves. When I undo everything and try again, sometimes it works, but them sometimes it doesn’t. I’m not sure why this is happening, although I suspect it might have something to do with not touching on the correct little brown box/red circle on the screen. I can see many but as the other elements are locked I am moving the only one that can, and the camera/viewscreen moves with it each time (plus the correct element in the timeline remains selected) so I think I am doing it correctly. Why then are earlier motion keyframes sometimes going out of alignment and sometimes not? I only have one frame in the timeline selected, not the whole element. A change at a later motion keyframe in principle should not affect an earlier motion keyframe.

My other problem is, again (I’m sorry), with the scene-planning/select tool to change z-space. I just cannot get this to work. I tried touching the screen on the blue pivot point and a million other places to change the focus to the screen, but still the character/element in question will not move in z-space. It will move in Y and X space, but not in Z space.

When I press control/alt, I do not get the double up/down arrow. All that happens is the corner points on the black-pointed bounding box disappear (leaving only the four black points in the center of each side of the box). If I hit the up/down arrow keys, the character moves up or down in Y space but not in Z space.

Also, I do not get the same properties window allowing me to adjust the z-space by entering in new forward or backward values. I only get that properties window when I am on a drawing element, not when I am on a peg element.

Basically, I have a chicken who is skipping along the bottom of the screen. It passes in front on a monkey. I have the chicken peg well above the monkey peg in the hierarchy, but parts of the chicken disappear behind the monkey as he skips past the monkey. All I want to do is set the chicken so that he is in front of the monkey. I don’t want to do it with the motion tool because then the chicken will change size as he moves and I don’t want that. I know the sceneplanning/select tool is the one to use, but can’t understand why it won’t cooperate.

Sorry for all the questions.



You are right in saying that a keyframe that is locked in time should not be affected by other keyframes. However, I am having trouble understanding your issue. You can send me your project directly with detailed steps if you want me to look at it.

If you are still having problems picking the correct keyframe in the camera view, another option is to use the Function Editor window. It is more complex to use but allows more detailed control on the keyframes.

For your question regarding the sceneplanning select tool and Z shifting, the shortcut is Alt and if the focus is in the camera view, it should work with the up and down arrow.

The effect is very subtle however. Especially if you are doing it on the current camera’s parent peg.

It is normal that the cursor does not change. Also the offset values are not shown in the Properties window for Peg layers.