How can disable auto-selecting other layers

When I’m using the Layer Transform tool (either in the Stage view or the Top View/ Side View window) to move elements in my shot, I keep accidentally selecting other layers. Even when I lock the other layers it still selects them in the Layers panel even though it doesn’t move them, and deselects the layer I’m working on. It’s infuriating and slows down my workflow, how do I turn this off?!

Still need help on this one,

I can’t find any relevant information in the Storyboard Pro 6 notes aside from toggling the Global Layer Navigation in the General Preferences. This doesn’t solve the problem since whether it’s selected or not, when I’m working with the Layer Transform tool, it will select other layers than the one I’m trying to work on.

I’ve tried hiding AND locking all other layers in my panel, and unless I am extremely precise in where I’m clicking, it will deselect the layer I’m trying to manipulate, forcing me to stop what I was doing and reselect it in the layers panel.

I’ve been boarding in Photoshop before upgrading to Storyboard Pro, and in Photoshop all you have to do is toggle a little option called “Auto-Select”. This is nice for when my elements are cleanly separated, but not when I have numerous overlapping elements on different layers, and was a royal pain in the neck before I realized I could turn it off. With the option turned off you can click anywhere on the artwork and move your selected layer, regardless of whether or not you are selecting the right pixels or not.

Is there a way I can work like this in Storyboard Pro? Is there an icon/button or a setting/preference I’m missing?

As an added layer to this problem, I’m having a really hard time selecting my drawing with the Layer Transform tool (on a specific layer) ONLY in 3D mode. When I switch to 2D mode, it gives me the blue bounding box around my drawing and I can move it around just fine. The problem here is that it seems to reset all of my layers which I had laid out in perspective in 3D mode, and flattens them to the same plane.

It seems like the problem of not being able to select my drawing (again on the only unlocked layer on the panel) isn’t always repeatable. Sometimes no matter what I do I can’t select my drawing, and other times I can futz around with it until I can drag it around in the frame.

I have wasted HOURS on this issue

What is the solution?


I think its better that you contact toonboom support direct.

Then you will get a quicker answer. When you add a question here you never know if anyone will answer but sending a supportticket they will.

/ Mattias

The way to do a layer transform is to first select the layer
and click on the stick figure on the layer sidebar of the
“Stage View” window (this makes a keyframe).

You can make additional keyframes using the “Tool Properties”
Window. Note that layer transform keyframes are under the
Timeline as opposed to Camera Keyframes which are above.

You can also make and delete keyframes from the L: A section
of the timeline which is at the level of the layer transform keyframes.