Hold Timing Node - Major Lag


When using the hold timing node underneath the master composite of a rig there’s major major lag that occurs not only in camera view but selecting tools just in the UI.

I’m trying to use dynamic springs for hair in a rig which I’ve done plenty of times, however this time it needs to be able to animate on 2s. I’ve tried checking the animate on active attribute option in the dynamic springs but it’s simply just too finnicky and unpredictable for animators, it also needs too specific of conditions to work as desired. This is the same case with trying the hold transformation node.

The Hold Timing node under the whole rig on the other hand, seems to work really well and is great for when animators need to implement feedback as tweening is still available (as oppose to re-animating frames that have been baked down). It’s the most straightforward and editable. The lag is just insane though and I don’t want to put my team through that, for now I just have a check box controller to enable/disable the node whilst working.

It would be really truly great if there could be a patch update for this node.