Hidin layer hides whole composite

Hi,
I have this very weird issue with Harmony 16. If I hide a layer that is last connected (rightmost) to a composite, it hides the whole composite which effectively hides everything connected to that composite. Is this a feature or am I missing some very obvious setting? My current workaround is creating an empty drawing which I then connect to every composite but this solution is far from ideal. Any new drawing is automatically connected as last in composite.
This issue is only happening when I’m hiding a layer in timeline view. Hiding it in a node view works just fine even tho it should be the same thing but this isn’t solution. Is there a difference between hiding a layer in timeline and disabling it in node view??

Please help before I go mental :smiley:

Hi Davoo,

Can you do a screencast showing the issue that you’re coming across?

You can use tools such as screencastify that is browser-based.

I would love to understand if this is a usage question and get our trainers to give you some tips or Harmony behavior.

Best Regards,

Edgar
Technical Support Specialist
Toon Boom Animation

Sure thing and thanks for replying so fast.
Here’s a screen: http://screenshots.pixelfederation.com/da/Photoshop_DG5mTCgyj7.png

The thing is in the timeline view the composite is inside the “Drawing” layer (because it’s the rightmost layer connected to it) and when I hide that layer it also hides the composite which also hides all other layers connected to it (Draing_2). I understand the composite has to be somewhere both in the node view and timeline view.

My guess is it’s just the way it is (even tho it used to be different in older versions), rather than any real issue. The problem is, most of the people I work with are used to just simply hiding the layer they don’t need during animation and hiding the last layer hides everything.

As I see it the only viable solution is to teach my coworkers to start using enable/disable shortcut instead of hiding layers unless you have some other solution? :slight_smile:

+1
oh hi! I have the same issue with the current illogical behaviour of Composites in the timeline!

Also I have a proposition for a change of this - hopefully for the eyes of someone from Toon Boom dev. team here - https://forums.toonboom.com/harmony/support-and-troubleshooting/counterintuitive-handling-composites-timeline

cheers

Agreed. I understand why it is made this way. In lower versions the node view is not available so the composite HAS to be somewhere in the timeline but the way it is handled right now is not ideal. I wouldn’t mind composite being under the last drawing layer as long as it wouldn’t inherit it’s visibility state.